DSO power on only with USB plug connected, not with battery!

Hi at all, I recently purchase a DSO Quad from an ebay user.

I notice it work properly (I updated it right now without problem), but it doesn’t power on even with a good level of battery charge.
I can work with it only if the USB plug is connected, not with battery!

It seems to have some problem, maybe with battery charging, but I can always read the value Vbt=+4.18 when I switch on it with USB plug (even with battery disconnected :astonished:!).

I think it very strange :confused:, any idea? Thanks in advance.

Disconnect the battery and check the voltage on battery.

Battery voltage is 3.72v, it seems to work properly. The red led is always OFF if I try to charge the DSO (as though the battery it was fully charged).

Check the voltage at pin 3 U19 and pin 4 U14 (cable USB disconnect).

I tried your suggestions and I found (first of all) 0V on any single pin of U14.

Then, I removed the metal plate and I found a strange position of battery plug, a bit tilted, so I tested it and… if I pushed to mainboard it, I could alway see the DSO power on :astonished:.

Then I understood :open_mouth:, the problem it was the battery plug on board.

I think that old DSO’s owner has done a bit of damage pushing the plug to connect the battery!
By some small soldering of plug pins of mainboard the problem was successfully solved :smiley:!

I’d like to thank everyone for the support :ugeek: :slight_smile: :wink:.