DSO Nano v3 won't connect to my computer

Hi all,
I have a DSO Nano v3 with upgrade V3.26D (exactly how it came out of the box, I have not changed it at all). When I plug it into the usb drive of my computers, nothing happens. It is not recognized as a virtual disk drive as it is supposed to. Here is what I do:
I plug the device into the computer’s usb drive
Hold the “down” button and turn on the device
I have tried this on windows 7 and windows 8 on multiple computers (laptops and desktops) but still nothing happens. I tried downloading the stm32 driver (which I later read is not required for v3) and Dfuse (I found out later this is also not compatible with v3). What steps should I take to try to find this device on my computer? (Step by step would be appreciated as I am somewhat computer illiterate when it comes to this sort of thing)

What happens when you connect it without pressing the button?
Your windows should then install a driver for it, and you should see the contents of your SD card, if you included one. If I correctly recall it, windows must first install a driver like that, and next what you try should also work.

If I connect the nano to the computer without turning it on while holding the down button nothing happens. I had the device manager search for new hardware and still it found nothing. Since my initial tries, I have also attempted to connect it to a linux ubuntu os computer as well as a mac but neither of them could find the device either.

Sorry I meant the opposite: it should see your device and try to install a driver if you switch it on and connect it without holding the button down.
If the computer doesn’t see it at all, it may be that your device is defective…