DSO Nano V3 Troubleshooting

I’m Getting a white screen after BenF V3.64 upgrade?

It started when I went to do the upgrade. I did not have it in the “Device Firmware Upgrade” mode and put the file in the drive letter that the device created E:\ (e-Design DSO Flash Disk USB Device)
But the drive did not disconnect and reconnect to change the file extensions. From .hex to .rdy .err

So I disconnected it and reconnected with no change???
I should have noticed that it was not in the upgrade mode, but I did not. Turned device off and back on…. Bright white screen. I it sit there for a few min with no change. Turned it off and went to do it again, and but this time I booted into the Upgrade mode. That screen worked fine. Booted into the device info screen, it worked fine also. So I am back into the upgrade screen this time I get drive letter E: (DFU V3_26_D). I copied the files for BenF and the drive disconnected and reconnected file names changed ok everything looks good??? Reboot device white screen!!!

So I used the only other Firmware I had, DSO Nano 2.6 firmware booted into upgrade mode copied file it disconnected and reconnected Files extensions changed, ok reboot. . .
Gray (vertical bars of white and black) Screen

Frantically looking for another firmware and found the one on the Seeed Sudio Product page. So I attempted to use the file from there. Booted into the upgrade mode copied the DSO V4 file The drive disconnected and reconnected, disconnected and reconnected, disconnected and reconnected, that’s strange??? After 4 times opened the drive and the file name changed “DSONAN~1.RDY” ok reboot. . .
I get a gray (alternating lines of black and white) screen that flashes the seeed studio logo upside down and in reverse color (logo background in white letters in black)

When I press buttons the screen flickers like it does when it changes menus. It seems like it’s working but I can’t see anything but the gray screen . . . the random flashing stops when you press the hold button

Thinking for some reason it may be the files that were left in the drive you get in normal operating mode E:\ (e-Design DSO Flash Disk USB Device) I connected it to USB a window pops up and tells me the drive is not formatted or there is no drive plugged in??? and the fist time it poped up it wanted to format it to a capacity of 6.42 GB I closed the window, disconnected and reconnected same thing drive must be formatted tis time 2.27 GB??? Closed the window . . . turned the device off and started this thread

Files used:
BenF >> DSO BenF APP v3.61_00.hex , DSO BenF LIB v3.52_00.hex
DSO Nano 2.6 firmware >> 201AP263.hex , LIB_A227.hex
DSO V4 >> DSO Nano APP4.0.hex

Device Info:

Serial: D5D3D9CF
License: D5DA20B3
Device Firmware Upgrade V3.26D
Hardware: Version 3.00
MCU Type: STM32F103VB
LCM Crtl: ILI_9341
USB Disk: 2MB internal

Dear All,
I am experiencing exactly the same problem with a DSO nano v3 and there is no way to get back to the initial firmware.
Is it possible to perform a factory reset? any other solution?

Many thanks in advance

I was thinking it was odd that there was not a LIB file for the DSO Nano APP4.0.hex so I used the one from DSO nano V2.6 Firmware (LAB_a227.hex) I get the correct splash screen logo is the correct color and the right side up. . . but it never gets past that

Does anyone have the LIB file for firmware 4.0

Hey I distribute Dso nano v3 and messed up several of them this way.
Finally found 4.11 which is what comes with the nano now, also found 4.20 and managed to update to that without problem.
Found out that Benf is no longer compatible because the sd card was removed. So…
Here I’m attaching the zip file with the required hex’s.
Don’t have time to, but if you can contribute it to the wiki it would be nice!
201V4-11.zip (31.5 KB)
201AP264.zip (29.1 KB)
201_L228.zip (17.4 KB)

Forgot to attach 4.2 if anyone is looking for it.
201V4_20.zip (39.3 KB)

Great!!! it works.
many thanks.

Thank You it works perfectly :smiley:

Hi, I have an DSO201 V1 with firmware V3.26D, I tried the benf firmware first and got the white screen, tried every hex firmware I could find with little luck, most white screened and some had inverted color start up logo-freeze.

I tried 201V4_20 and it restored working but it’s stuck on auto and a “demo only” logo floats around the screen in orange … same with 201V4_11

The other files:201AP264,201_L228
don’t seem to help and I get the same result if I include these or not.

Also this originally came with Paul’s V1.5 firmware, when I try to restore that I also get a white screen…

Any ideas or advise would be greatly appreciated


I just got a V3.

Could someone please tell me how to find out what firmware is on board?

And also does anyone know how to get rid of the purple DATA trace ?


Reinstalling original program will cure prob, see my other pages with link on ver 4.22 is out now G4VVQ Fred uk

1 Like