DSO Nano V3 : Phantom square breaks voltage measurement

Hi everyone. :slight_smile:

I just got my DSO Nano V3
Tried 4.11 (stock) and 4.20. BenF firmware won’t run (see down for details)

A video worth hours of speech
I can’t post links because i’m a new user, so please copy the link and remove the space :arrow_right: youtube. com/watch?v=BcYiwBBIRDk

:arrow_right: As you can see, there is a kind of square signal appearing even when i’m not plugged to anything.
It never disappears, so i just can’t read accurately the max peak (and so peak to peak) value… Ihe min peak is OK.
The value of this phantom signal also changes proportionally with the Yn axis (it always takes the same space onto the screen). :unamused:

As several people, i can’t install the BenF firmware, it just displays black and white vertical lines (tried several ways tu flash it, but it didn’t work). :cry:

So, is that it ? Am i (are we) stuck ?
I need this tool so much to make audio/electrical measurments, tests, etc…

I’d be so grateful if any help was given. :slight_smile:

I am sorry to hear this. The DSO can not work normally, whether you have upload the wrong firmware?
And you send to link ,I can not open and there are no way to see the problem.

Hi, thanks for answering.

For the youtube video, just copy the adress and remove the space between “youtube.” and “com” and paste it in the URL bar of your browser. The link should be OK, i tried it again.

I don’t think i upgraded to the wrong firmware, as the V3 is the only one running a V4.xx firmware. But BTW, if you’ve got an official link for the official firmware (or a custom one that works perfectly), i could try it and see what happens. It would be very appreciated as i’m a newbie to the DSO Nano world, and as i must say, the support isn’t the easiest i’ve seen.

Hope i’ll get some news soon guys, thanks in advance. :wink:

So its working now or still need firmware what firmware is on it now

I made a earlier post thats titled another dso firmware question that has the file for v3 firmware. Looking at your settings i seen that the ex function was set to -inp try scrolling to that and selecting off the ex function is for viewing saved waveforms.