DSO Nano v2 faulty after running out of battery


my DSO Nano v2 worked fine as long as I used it on my desk with usb cable plugged in.
Last week, I used it on battery to measure a knock sensor signal in a car. This worked fine for hours until it run out of battery.
After that I plugged it into the usb port to charge it; the dso nano v2 still worked fine for some time (~30 minutes).

But suddenly the screen has gone dark and my dso nano v2 stopped working with usb cable plugged in.
It boots (display is working fine) if I turn it on without usb cable but goes out after a few seconds (battery is not full although the usb cable was several days plugged in for charging it).
With usb cable plugged in it does not boot at all (the screen only flickers black / white).

Could a faulty battery cause such symptoms? How can I check the battery?
Or should it work with plugged usb cable no matter if the battery is ok?

Thanks in advance

1.DSO Nano can work with the usb cable pluged into PC ,with no battery.
2.I suggest you carrying out the battery, and pulg the usb cable to have a try. (purpose:check if the battery was short. if it works with no battrey, maybe you need to change a battry; if it still not work, maybe the power circuit need to be checked . )
3.if you bought it from seeedstudio and you need our checking and repairing, pls emil me: luogang@seeedstudio.com

i have the same issue !
i have nano v1 .yesterday was using it until the battery drained , now it wont charge the battery , and wont work from usb cable .
it shows “usb” on the display , but the display goes dim and it shuts off .
left the battery to charge for few hours and it dind charge at all .

i was able to fix my nano .
the problem was with the on board charging ic - ltc4054 .
this charger gets really hot , but its the way it works , as its got internal thermal protection at 120 *c .
i bought my dso on ebay (wasnt even aware it was made by seeedstudio) so it be a knock off .
this part should be marked as LTH7 , but mine was marked with a different number , so it might be a cheaper part , i dont know .
anyways , i bought the right part (ltc4054) from ebay , soldered it up , all works fine now .well . my dso looks bruised now , as all the panels are glued to it ,and it wont be the same after reassembly .

btw , it wont power up without battery , it just blinks constantly .maybe my usb port power is not enough , i dont know .
but it charges the battery fine now (and works from usb port) .
heres the pic of the part after replacement:

That bottom right hand pin looks like a cold solder joint from here. Maybe you should re-solder that one! :slight_smile:

lol , i know .its just too much solder . it works so far :smiley: