DSO Nano v1 - "Disk Busy" on read/write to SD


I am using a DSO Nano v1 oscilloscope with firmware version v4.28. I tried to save some waveforms to an SD card, with no success.
I tried it with a Kingston 1GB SD card, formatted to FAT16. I also tried pre-saving files in the format “FILE000.DAT” and “FILE000.BMP”, to no avail. I tried following the guide for Nano v2 found here, but it didn’t help me.

When I try to write a waveform to an SD Card, Nano responds with “Disk Busy”. I am not sure what to do with it. Is there some issue with the firmware, and is it possible to fix it?

Did you ever sort this?

I’ve got my DSO201 running 4.21 out of storage to try and use it and found it too is giving me the “Disk Busy!” message if I try to access my 2GB Micro SD card no matter if its formatted to FAT16 or FAT32.

Expecting it to be an error in the current firmware, I try and reinstall the device Firmware by holding - while powering on, however the drive DFU V3_26_D momentary appears before immediately disconnecting before I can copy any FW to it.

So seems my device is stuck on a buggy firmware.

To answer my own question this error was due to the 2GB mini SD card I was trying to use. Switching to a 1GB card sorted it allowing me to save data :slight_smile: