DSO Nano, still in trouble with USB on XP

we own a DSO nano (DS0201V1.3A revision) with the well known USB problem under XP.

We already checked the R24 matter (which is 1,8K as required) and even tried to temporarily remove the D2 protection diode.

The behaviour is as follows: when we plug the device into the USB port, is it recognized as “e-Design DSO Flash Disk USB Device”. We then tried to manually replace the driver with both the one found on this forum and the “DfuSe_Demo_V3.0_Setup.exe” downloaded from the ST website.

Both drivers fail to install with the message “unable to find any hardware information in the specified path” (please note that this message is translated from italian so it may differ slightly).

We also checked the electric continuity between the D-, D+ USB plug contacts and the 22 ohm resistors on the PCB (so the cable and connectors are ok).

Since the hardware seems ok, we are wondering that it may be a driver or firmware problem. But since we can’t replace it through USB, we are unable to investigate any further.

What can we do now?

Thanks a lot and Best Regards

The Dfuse have a driver folder , try to update the DSO driver with this driver.

When you open the Dfuse.exe, can you see the device show in “Available DFU and compatible HID Device” ?