DSO Nano firmware v3 upgrade turning my wetware to soup

I’ve had a DSO Nano for almost a year now, and it’s worked fine for me straight out of the box. I’ve not tried to upgrade the firmware because it seemed as though the benefits were not worth the time and trouble.

I see now that there’s a v3 firmware upgrade by BenF, and at first glance it looked like it would be worth pursuing, but I’m mystified about what I need to do to actually do it. There’s stuff on a Google repository, and I’ve also found a “DSO nano firmware generation and upgrade.pdf”, but it’s out of date. It seems to lead one to believe that I then need to find a copy of IAR… it’s got me thinking this is a fool’s errand.

Is there an FAQ or manual that conveys the v3 firmware upgrade information?

Nothing has really changed as far as the procedure goes so the upgrade.pdf is still valid. You definitely want to upgrade to Ben’s firmware. All you need is the dfuse V3 software to update the firmware (both the app and the lib) available here: dsonano.googlecode.com/files/um0412.zip

Thanks, but this didn’t help me much. Two hours after working on this upgrade, I’m stuck.

Here’s what I’ve done so far, using the “DSO nano firmware generation and upgrade.pdf”:

  1. Found and downloaded the IAR Embedded Workbench IDE for ARM. I had to register to do the download, and I received a license number AND a key.

  2. In dsonano on google, there are three files for download that were all uploaded three days ago–I downloaded all three since there is no apparent indication (to me anyway) which one is the correct one.

  3. After the download to get the 500mb Workbench software, unpacking it and installing it, I launched Workbench, tried opening all three of files and running rebuild all. All three have workspaces that look something simliar to the one in the upgrade PDF, but only one workspace is called Debug_FLASH–is this the correct one to use?

  4. About 15 seconds after starting the ‘rebuild all’ command, Workbench complains: “Fatal Error[Cp001]: Copy protection check, Your time limited license is out of date - You must register NOW to get the permanent key in order to continue using this product!”… so I quit Workbench and ran the IAR systems licence activation application, making sure that the correct key etc is there–it sends me back to the website to confirm all this (I can’t believe the red tape just for a lousy 30-day trial!), and the website response is that I am indeed registered, but it may take 5 days for it to be confirmed. :question:

I MUST be way off track–things cannot be so convoluted simply so that I can upgrade the firmware on my DSO nano…?

None of the steps you describe are needed, none of the documents you referenced are needed and none of the software packages you downloaded and installed are needed.

The upgrade procedure is described in the manual that came with your DSO. You can donwload a copy of the manual from this link if you need it:


Starting on page 8 you will find a step by step guide to upgrade your firmware. If you follow this guide, you should be up and running with new firmware in a matter of minutes.

Thanks, got it! :smiley:

The Nano seems to be working for me, with the exception that the right arrow does not do the inverse of the left arrow.

As I mentioned in my previous post, the v3 firmware didn’t work for me: the right arrow button, which should provide the opposite function of the left arrow button, actually behaved either as the up arrow or down arrow buttons, making it unusable. :cry:

I went backwards to 2.5e, and it works fine in this configuration. I’ll keep an eye on things here and keep trying the firmware upgrades as they appear.

This suggests that you have a faulty rocker switch. That is when you press “right”, the switch will connect more than one key (up, down or both in addition to right). The firmware will then act on the key with the highest priority and this could very well be different in the 2.5 and V3 firmware.

Most likely the key top is positioned too close to the underneath switch and would somehow have to be pried upwards on the right hand side. Possibly your top cover frame is slightly dented or the switch itself is a bit high on the right side.

If the switch is faulty, would the fault not also appear when using v2.5 of the firmware?

Not necessarily.

I looked up the source of both versions and this checks out.