DSO Nano 201 V3 - wont connect to PC to upgrade FW?

Just got a DSO Nano 201 V3 (FW 3.29D?) to try and monitor car battery/alternator voltage on startup.

Only problem I have is that I would like to upgrade the FW to BenF. When I connect the Nano to the pc via usb I can see it as a removable storage device but if I boot into Firmware Update mode (Power & -) then I get a ‘Unrecognised USB device’ error message on WinXP, and Win7.

Any ideas?

I had the same problem. I tried another mini usb cable I had around and it worked.

Any update on this? I have a gray screen, the device is in DFU mode but no drive.

The USB cable supplied with the V3 is a power cable with beefed up pwr and gnd but no signal wires. You need a data cable… your cell phone cable should work.

I have the same problem. In Win 10 I get a new removable data device in Explorer, and then a message “Insert a data storage media into the device” (Sorry, I’m German, so the actual English message will differ a bit).
I tried with different USB cables, but the result is the same.
Interesting detail: I go to properties of the removable device, and to the hardware tab. There I see all my devices and a new one “Vertual DFU Disk USB device”.

Another detail; When I leave my DSO plugged into USB, and boot up to the boot start menu, there is this “Vertual DFU Disk USB device”, too.

But I never come to the state, where I find the DFU virtual device in Explorer and can copy the dfu files there.