Dreaded "File NoPlace" error and BenF firmware

I’ve read all sort of hints and threads to solve the microSD file save problem. None of them seem to be the definitive solution to the problem, and more specifically doesn’t actually point clearly to the right way of formatting the card.
I tried with winXP (it doesn’t let me select FAT16, but simply FAT), and the sdFormatter, with no luck either way.
I tried saving with an empty SD or with the SD having the folder DATA and files file001.dat … again with no luck either way.
Anyone a definitive guide to troubleshoot this problem, and any fix to the firmware?

And talking about firmware, does the BenF 3.xx also apply to the nanoDSO 1 or just to v2?

Thanks everybody.



Perhaps this is unclear to other readers, but the “File NoPlace” error relates to the Seeed firmware. I was never able to get the SD card working properly with the Seeed firmware and so can not help on this.

The BenF firmware will support most standard SD cards formatted to FAT-16 for use standalone or as a mountable file system. You can use the firmware with both V1 and V2 hardware. A user guide is included with the download and there is some additional info on SD card requirements in this document.

Thanks. Much appreciated. I’ll give BenF firmware a try.

I uploaded to BenF firmware succesfully and it’s much easier to work with.
Still, I now have a “No File” error when trying to save Img, Ref or Pro. Creating the files myself, doesn’t help. Formatting with SD formatter doesn’t help. My SD is a standard 2GB from Sandisk.

You may want to watch this instruction video by lwgraves on how to use the Nano with a SD card (this is part of a tutorial series).


If you follow his instructions exactly and still experience issues I would try a different card.

I tried reformat and repartitioning to no avail. I tried resizing the partition, to make it more looking like the one in the video. I noticed the SD of the video is 1.83 gib, my is 1.86 gib.
Do you know which type and brand of microSD is guaranteed as working?

I just picked up a SanDisk 2GB MircoSD card on e-bay. Here’s a captured image:


I have a sandisk 2gb as well, but it refuses to work for me.

I took another 2gb sandisk out of my mobile phone, and hear hear… it’s not working either.

You’re certain it’s a “MicroSD” and not a “MicroSDHC”?

The “No File” error suggests that the Nano was able to detect your card and successfully read the partition table. Next step is to create the file (and directory if needed) and this is where it fails. There really aren’t any secrets to getting this to work (besides type of card and correct formatting) and so there may be a hardware issue (card, cable, Nano).

To check further, you may want to try the following:

  • Make sure the card is of the SD type (not SDHC)
  • Try with a different USB cable (reformat with new cable)
  • Try to save to file when operating on battery power and also when powered from USB
  • Check if you can read/write files from the PC when Nano is connected as a USB disk
  • Run checkdisk/scandisk to check the SD card for errors before/after failed write attempts

Yes I confirm that without the SD, it fails with “no card”. So the SD is correctly seen and mounted.

The card is SD type, formatted with FAT16, with XP and/or with sdformatter.
Reformatting with a different cable doesn’t help, still “No File” (I have a NOKIA-branded cable and also a standard off-the-shelf cable).
Saving with USB cable or battery power doesn’t make any difference.
Scandisk ends with no errors.
I can read the SD card from the pc (XP Pro), I can create folders and files, and delete folders and files as in a removable device. I can also make the above with SD card in the DSO Nano and connected via USB.

It’s a microSD. 100% genuine SD from Sandisk.

Are you seeing the same issue if you format to FAT32?

One more thing you could try is to reset to factory defaults. Choose menu “FI”, option “Load Pro” and then “L Factory”. This will reset all configurable parameters to reasonable defaults in case something was carried over from other firmware versions. Note that if you recycle power, defaults will be back to whatever you had prior to reset (follow reset with save to Flash if you want to keep the new configuration).

Formatting with FAT32 freezes the DSO.

I have L Flash, not L Factory. Anyway did that, and nothing changes, still NO FILE.

Save to Flash returns SAVE OK. Recycling the power reloads the configuration saved.

Moving one left from “L Flash” should take you to “L Factory”.

Make sure you run the latest version (v3.62) from this link:


I’ll update and keep you posted later today. I’ll be back. Thanks so far for your help.

Eureka! It works!

THANKS EVERYBODY especially BenF for his/her help!