Does the XIAO need a usb3 on the host computer?

The host computers make the baa-dink sound when the XAIO is connected but the double reset doesn’t change the behaviour, no flash drive appears and my keyboard stops working. I’ve tried two keyboards and it’s the same behaviour. The PC needs restarting to get the keyboard back I’ve tried two XAIO boards and the behaviour is the same. I’ve switched to different USB ports on the computer and still the same behaviour. Do I need to buy a USB3 card for my computer? Thanks.

I have it working on a standard USB 2.0 (hub) port. But I’m using Linux (SuSE). Maybe your XIAO is defective. I have killed 3 of them by now. But this seems to have to do with bad power supply connected w/o USB.

Hi rocketz,

Please tell me your situation.
1.Are you trying to connect the XIAO to your PC for the first time? Or have you ever run a program on the XIAO?
2.Is the XIAO for Arduino or CircuitPython?
3.Is your PC OS Windows or Linux?


Yep, the two XIAO’s were fresh out of the packet. I tried different keyboards and mice but same problem.

Today I let the latest win10 upgrades go through and it now works. And that’s on a USB2.0 because that’s all my computer has.