Do you need Arduino IDE to do a aip build?

When I did the first “aip build” a lot of files were downloaded, ArduPyCore-sand, gcc-arm-none-eabi, bossac, mingw32, Seed_Arduino_CMSISAtmel
Unfortunately the build didn’t work because of some Path issue as mentioned in my previous post.
Can someone give me more details on how to do a “aip build --board=xiao”.
Should I have Arduino installed before installing ardupy-aip?
I installed ardupy-aip from inside a python environment. When I did a “aip build --board=xiao” all the files I mentioned above were installed (I do not know where) outside of the python environment.
When I remove ardupy-aip using pip all the above files do not get removed?
How do I remove these files so I can start the process of getting ardupy-aip working?
Lakshantha 's videos are good but there is no troubleshooting of the compilation process.
Any help really appreciated

Problem Solved.
When I installed ardupy-aip it put all the gcc compile “stuff” in the directory …
I did a aip build -v and it implied that the aip directory should be in …
I checked and there was no aip directory in C:\Users\xxxx\AppData\Roaming so I moved the aip directory from C:\Users\xxxx\AppData\Local\Packages\PythonSoftwareFoundation.Python.3.8_qbz5n2kfra8p0\LocalCache\Roaming to directory C:\Users\xxxx\AppData\Roaming
Then “aip build --board=xiao” worked !!!
Don’t know why the aip folder was put in the wring place

Please follow this thread:
Aip build not working - Products & Technology / ArduPy - Seeed Forum (