dfu-util problem: "cannot claim interface"

Hi, I am trying to upgrade my DSO Nano 2 to BenF 3.64, and I’m having trouble with dfu-util. Here is what I get:

Opening DFU capable USB device... ID 05ac:8218 Deducing device DFU version from functional descriptor length Run-time device DFU version 0100 Claiming USB DFU Runtime Interface... Cannot claim interface 3

I have searched and searched and can’t find any solution to this problem. :imp: Any ideas?

I forgot to mention that I am using OSX. This is the command I am entering in Terminal:

dfu-util -a 0 -D DSO\ BenF\ APP\ v3.64.dfu

and I get this when doing dfu-util -l:

Found Runtime: [05ac:8218] devnum=0, cfg=1, intf=3, alt=0, name="UNDEFINED"

Looks like a permission problem. Try prepending the command with “sudo”.

Tried it with sudo, but I still get the same result.

The USB device with ID 05ac:8218 is not your DSO Nano but a Bluetooth host controller which also can be upgraded over DFU. dfu-util would have complained if it detected several DFU capable devices, so it seems that the Nano is not detected (at least not as a DFU capable device). Are you sure the Nano is in DFU mode (displaying “firmware update…”)? You powered it on while pressing the down key, right?

What does “system_profiler SPUSBDataType” say (I don’t know of a better lsusb -v equivalent on MacOSX)? Maybe you can get more info with “sudo system_profiler -detailLevel full SPUSBDataType”.

Thanks so much for your help! Actually, I forgot to put the DSO into DFU mode. :blush: Then I also had the problem with too many DFU capable devices, but solved that by turning off bluetooth.

Glad you got it to work! Having many DFU capable devices is not a problem, you can use -d 0483:df11 to specify your Nano in this case.