DFU Mode not working !?!?!?!?

Hello !

i search desperate for help.

I have a minidso DSO203 quad.

Hardware v2.72

i can not enter the DFU mode … i start with // + Power on it displays DFU but the drive on the PC is not formated and i can not format it !

Anyone can help ???

Thanks in advance !

Edit: when just powering it on i see working Drive on my computer (8MB)

damn it was a problem with a removeable diskdrive i switch to another drive character now it works

i want to try gabonators APP but it is not on the github anymore

anyone can help me out with: APP_G251.hex

thanks !

But what did you do? Did you actually format the drive… please help me , i changed the drive letter but not working.

Windows recognize the “Vertual Disk Usb” but it has no format.

I have the same problem. It appears on my PC (as ‘DFU V3_12_C’), but I cannot copy anything to it. If I right-click on it, I can get basic properties.
If I just switch it on (no >|| key) it appears on my PC as ‘DSO’ and I can copy to it.
I have tried Windows 7 and Windows XP.
Tried different USB cables and ports.

Please help :frowning:

Hi. I have the same problem. the ‘Vertual DFU USB Drive’ appears for perhaps 1 - 2 seconds and then disappears. There is no drive appearance to format or do anything with.

Hi all,
I managed to get my DSO Quad sorted. Here is how I did it:-

  1. I connected a USB to Serial board to the UART at CN7 on the Printed Circuit Board.
  2. Mine created a serial port at COM1.
  3. I used the stsw-mcu005.zip from the STMicroelectronics web site. It is a Windows GUI for flashing the CPU.
  4. FIRSTLY I downloaded my existing firmware from the DSO Quad and saved it.
  5. I then tried a variety of Bootloader .bin files and ended up with the need to put a Licence code in each time, but at last I was able to see and use the DFU Mode
  6. I then tried a variety of SYS.Hex and APP.Hex but had a problem with the top line menu in scope mode not formed correctly.
  7. I flashed my previous firmware back into the quad (see step 4).
  8. Hey presto everything now works properly again.

I hope this helps anyone else with a similar problem.

DFU USB drive only came up when you press #1 hold and power up ( the drive is 512k and free is 492k)

USB 8Mb only show up on PC if you just plug in to PC by USB cable and turn On no key Press , you will see the PC detected and the drive show up when you go to my computer and that drive will be around 7892 Kb , hope this help you.

i’ve the same problem… i can’t copy any files on my dso203 DFU V3.12C (HW2.72)…

in Win 8.1 (64Bit) there is neither the drive showing up…

on win 7 (64Bit) the drive shows up, but as i start coping or try to create a new folder or file the drive disconnects…
also same behaviour on XP …

any suggestions??

btw. i tried differen USB Cables too!

i’ve also found this thread… where they have the same problems…

Same problem here on two Win 8.1 machines… the DFU drive is visible but will produce errors and/or disappear when trying to access it. BUT it works perfectly with my old Win XP machine (which I still keep around to help with exactly those kind of compatibility issues).

Same problem here. Works fine on an old XP machine, but no good on a modern one with windows 7/8

DFU problems seem to fall into 3 categories.

a) DFU drive never appears
b) DFU drive appears but then disappears after a few seconds
c) DFU drive appears but cracks up when a file is uploaded to it.

I use Win7 64 most of the time and haven’t experienced a or b, so those are not intrinsic to Win7. They could be driver problems or in the case of b) there may be some other software which is trying to do something to the drive when it appears (virus scanner, file sync program, media scanner etc). I guess the latter is more likely for people’s Win7/8 installations compared with XP. DFU isn’t really a drive although it is presented that way on Windows and can be a bit flaky if any other than a regular file update is performed and that could cause it to disappear if anything else is trying to access it. If trying different ports and checking USB cable haven’t helped then two extra strategies here would be to try to get the driver to re-install (uninstall in Device manager) if it can be seen. It might also be worth booting in Safe Mode and seeing if it works there as this could help diagnose if other running programs are causing the problem.

For case c), which I have experienced, the issue for me was with just some particular hex files that DFU objected to (e.g. PAWN11). Re-organising the short hex records near the end fixed that for me, but I couldn’t work out why.

I think this could be more hardware related than software.

For a bit of testing, I installed some clean OS on a spare hard drive on my PC (i7 920, X58-UD3R). I put Windows 7 32 bit, windows 8 64 bit, Ubuntu 12.04 32bit and it wouldn’t work on any of them. That’s using both the internal USB2 ports and PCI card based USB3 ports.

However on my HP Microserver, it works perfectly on a 64 bit windows OS.

Perhaps the thinking that it’s XP which is working is based more around the fact that older hardware is generally more likely to be running it?