DepthEye3D issues on mac (H1AsciiSample)

Hello All,

I am unable to load the SDK Ascii Sample from the github instructions


I get the following warning when making the file

MacBook-Pro:build estre$ make

Scanning dependencies of target deptheye

[ 25%] Building CXX object src/CMakeFiles/deptheye.dir/DepthEyeInterface.cpp.o

[ 50%] Linking CXX static library …/lib/libdeptheye.a

[ 50%] Built target deptheye

Scanning dependencies of target H1AsciiSample

[ 75%] Building CXX object test/CMakeFiles/H1AsciiSample.dir/H1AsciiSample.cpp.o

[100%] Linking CXX executable …/bin/H1AsciiSample

ld: warning: directory not found for option ‘-L/Users/xx/Downloads/DepthEyeSdk-master/./lib’

[100%] Built target H1AsciiSample

Then if I run H1AsciiSample I get:

MacBook-Pro:build estre$ ./bin/H1AsciiSample

dyld: Library not loaded: @rpath/libusb-1.0.0.dylib

Referenced from: /Users/xx/Downloads/DepthEyeSdk-master/./third_party/voxelsdk_osx/lib/libvoxel.34.dylib

Reason: image not found

Abort trap: 6

Can anyone at least point me with a point of start? I tried looking into the ld warning but I can’t find anything useful. Any help would be appreciated!

Hi there,

Because the computer is missing the libusb library, please follow the guide to install the libusb library to solve the problem. thanks.