Damaged Boot Image - Wifi Shield V1.1

Hi everybody!

Is there an easy way to get access to the memory of the RN171 and redeploy a boot image?

I was trying to update the firmware in the normal way (wifly_update example) and got v4.0 to work, but there were many bugs and so I tried to use a beta version. During the update (ftp download to the RN171 according to the manual) of the beta version, I got an “out of memory exception” so i tried to delete some useless files from the RN171. During this action, the standard boot image has been damaged, although I’m sure I doesn’t touched this image.

Anyway, the result is, that the shield does not start/work anymore :frowning:

Is there any chance for this shield?


Hi Jeremias,

Have you tried restoring default configuration settings?

If it doesn’t work, we may ask Roving Networks, who designed the WiFly radio module, if there is a way to redeploy a new image.


Hi Yihui,

thank you for your answer!
Unfortunately the hardware factory reset takes no effect :frowning:
After reboot only the green PWR LED still lights up. It seems that no software were loaded by the RN171.

I tried to do the reset according to the method from stevdev in this post: http://www.seeedstudio.com/forum/viewtopic.php?f=23&t=4432&p=17962&hilit=GPIO9#p17962
Is this the right way?



Have a look at seeedstudio.com/wiki/Wifly_1 … leshooting