Connect LoRa-E5 mini to another mainboard via UART and control by AT command


I would like to control the Lora E5 mini by connecting my STM32 main MCU from its USART2 peripheral to the USART pins on the LORA E5 mini board.

I haven’t changed the existing software on the board which communicates fine with the PC and realterm.

I initially thought I could use a USBHost to control the dongle over usb but it seems that it is just a USB bridge.

The heading of the topic is a line from:

I would like more details as to how I would communicate with the LoRa E5 mini over usart from another controller.

My idea is that the data exchange between the two boards can be achieved by writing code for the UART to send AT commands

I’ve tried that but I can’t get it to LoRA E5 mini board to respond.
Is there anyone who has actually tried this and been successful?

Well I have used the Lora E5 mini board in serial mode without problems ! Have you properly setup the UART port on your MCU ? (speed, baud, parity) ? Have you tried also te reverse pins as TX/RX is always a joke for UART :smiley:

oh Great.

Did you have to change the existing software on the LoRa E5 mini as it worked out of the box?

I have connected from my usart on base nucleo board, the TX to RX2 and Rx to Tx2 on the Lora E5 mini.

As the heading says It implies that you can connect to usart on the lora e5 mini and communicate using AT commands. The board is not responding to my AT Commands

If it’s in original conditions and you have flashed nothing in it it should work with AT commands out of box ! Once flashed with a new firmware you are gone with AT commands (Seeed doesn’t supply the original firmware for reflash :frowning:

wrong the serial port you want to use is the one that is linked at USB interface so TX/RX ! and also try both RX on TX and RX on RX to be sure !

Did you try as stated in seeed documentation to connect the mini board at your pc in usb C and tries to send AT commands at it ? This way you’ll be sure the board works properly :wink:


I was using the wrong USART pins as it was the UART pins.

Many thanks for confirming it worked for you and the tips. I was about to give up.