Connect LoRa-E5-Dev-Board to STM32CubeProgrammer throws Error: No STM32 target found!

Hey there,

as the headline says I have problems connecting my LoRa-E5-Dev-Board to STM32CubeProgrammer to flash it or and remove the read out protection.

Step 10 of this tutorial
Wio-E5 Development Kit | Seeed Studio Wiki
is just not working for me and it shows me this error:

I found how to connect SWD to the official ST-Link V2 on stm32-base. org: [Guide: Connecting your debugger | STM32-base project]

So I connected
CN3 Pin 7 with the DIO
CN3 Pin 9 with the CLK
CN3 Pin 20 with the GND Pin
of the SWD-header.

I would upload a picture because Im not sure with the wiring but cant upload two. So here is a link:

Then I connect the ST-Link to my PC via USB, press down the Resetbutton and release it while clicking connect in CubeProgrammer.

At this point the tutorial is not clear about when these actions should happen exactly.

Should I try to release the resetbutton and click connect at the same time or release the resetbutton before or after clicking connect?

How long to press the resetbutton before clicking connect?

A video tutorial would be nice to see how pus and klick exactly to make it work.

I already tried all of these possibilities thats why Im here.

I also tried the different reset modes.

I updated the debuggers firmware, cubeprogrammer and installed the driver for st-link.

The steps before went well. I was able to connect the E5 to TTN using the AT-commands.

I also have a nucleo-wl55jc-board here that has an built in ST-link which I heard you can use to debug other boards but found not enough information how to do this. Doing so would help me find out if maybe my ST-Link is broken.

Restarted also my PC.

Im happy about help! Thanks!

Here, I found one answer. It says, “Hold a RST button while you click a connect button on STM32CubeProgrammer.”

@tepalia02 Thanks for researching! Where did you found this information?

As I said I already tried this variation of possibilities to connect the E5 with CubeProgrammer with no success…

If I cant make it run this week, im gonna send the E5 and the ST-link back to get another one and hope it was a problem with my specific hardware.

Here is the description where I dont see a clear way to go:

Step 10. After the above modifications, rebuild the example and program to your Wio-E5. Open STM32CubeProgrammer, connect ST-LINK to your PC, hold RESET Button of your Device, then click Connect and release RESET Button:

When I read it again, I think they mean:

Hold Reset Button → Click connect in CubeProgrammer → Release Reset Button

But then there directly appears the error… as well as when I
Hold Reset Button → Click connect in Cubeprogrammer & Release the Reset Button at the same time

Oh, I found my previous answer here.

Maybe I forgot to attach the link earlier. Or maybe it got deleted. If your problem is not yet solved, I think you can post this question to the STM forum too.

1 Like

Hi All,

I am also facing the same issue my st linkv2 programmer is not detecting with our custom LoRa-E5 module.

please suggest and guide me how did you rectify this issue?