.config/aip/ardupycore/Seeeduino/tools missing

Hi, for WIO Terminal I have started with ArduPy. On my Mac, I have installed AIP.

However, the whole directory ~/.config/aip/ardupycore/Seeeduino/tools is missing whereas the sister directory ~/.config/aip/ardupycore/Seeeduino/hardware/ is there.

How can I install …/tools ?

Thank you,
– Olav

Hi @olav577:
I would say, reinstall the AIP is a good choice.

pip install --force-reinstall ardupy-aip

Hi Hansen,

thank you for the tip.

The reinstall finishes successfully with

Successfully installed ardupy-aip-0.8.0 ardupy-mpfshell-1.1.2 colorama-0.4.4 demjson-2.2.4 pip-20.2.4 pyserial-3.4 pyusb-1.1.0 six-1.15.0 websocket-client-0.57.0

After that, I did a

(env) DWMB1031241:wio-terminal schettlero$ aip build --board=wio_terminal
Downloading ArduPyCore-samd-1.3.0.tar.bz2…
Using cached http://files.seeedstudio.com/ardupy/ArduPyCore-samd-1.3.0.tar.bz2 (20.2 MB)

This results in

Building Firmware for wio_terminal
sh: /Users/schettlero/.config/aip/ardupycore/Seeeduino/tools/arm-none-eabi-gcc/7-2017q4/bin/arm-none-eabi-gcc: No such file or directory

And in fact, there is only a hardware directory, no tools.

What else can I try?

Best,
– Olav

Hi @olav577:
1.rm aip/ folder.
2.run aip build --board=wio_terminal and please be patient during the building.

Hallo,
I have the same problem. using macOS Catalina.
I installed aip today and the build command doesn’t work

No of your Tipps worked

Is the current ArduPyCore download incomplete?

Now I know why it doesn’t download the tools because the platform os is undefined.

Python:

platform.platform()
‘macOS-10.15.7-x86_64-i386-64bit’

In parser.py are diffrent Os Platforms for Window, Linux and Mac defined, but not for my system

Hi,

I am on macOS Mojave, so this explains our problem. @Hansen, any chance that macOS Mojave and Catalina are supported? Sadly, for the moment, I am stuck with this old version of macOS on my company-supplied Mac.

Best,
– Olav

Hi olav,

I have modyfied the parser.py in /usr/local/lib/python3.9/site-packages/aip so that it recognieces my machine as an mac. Now it downloads the mac compiler and it seems it works fine. See line 59 and 60 in screenshot.

It’s a working around but I can’t geranty if the complier works 100% correct. The first test with seeed-ardupy-lis3dhtr has worked.

@has Can you send us a PR? We want to see your signature in the code.