Communicating over UART/USB with nRF Connect/Visual Studio

I’ve been working on programming the ESP32 C3 XIAO board using nRF Connect and Visual Studio, and the current thing I’m stuck on is getting it to talk over UART. I have it hooked up via the XIAO Expansion Board to a nRF52840 DK acting as a makeshift J-LINK; I have SWDIO and SWCLK connected, what else do I need to connect? I can’t seem to get any output even if I run the XIAO from a USB cable instead of connected into the expansion board.

@PJ_Glasso you’ve shown me that you use xiao boards with j-link etc, how do you get a serial output from them with the nRF SDK?

Hi There,
Great, Well when You say “UART” do you mean the USB serial port or the second port like on the nrf52840 Xiao sense it’s(pins 6-7) as is. With the ESP32C3 you have to configure the GPIO’s first.
from the data sheet I see this:

3.4.3 Universal Asynchronous Receiver Transmitter (UART)
ESP32-C3 has two UART interfaces, i.e. UART0 and UART1, which support IrDA and asynchronous
communication (RS232 and RS485) at a speed of up to 5 Mbps. The UART controller provides hardware flow
control (CTS and RTS signals) and software flow control (XON and XOFF). Both UART interfaces connect to
GDMA via UHCI0, and can be accessed by the GDMA controller or directly by the CPU.

On the jlink side there is also some possibilities , RTT etc. I don’t use that or the logger, I use Platformio and jlink or just nrfProg What are you trying to do?
I can use the USB port or the SWD(via jlink) to Flash on the Xiao’ BLE & Sense last check ESP32C3 board also. Give me more info I can try and help.
I mostly use the Nrf52840 BLE Sense device, but have the others as well.
I seem to recall reading something about the Xiao expansion board not being 100%compatable with the ESP32C3, may review that also.
I have a ESP Proggy too, I wonder if that is better for Debugging this ESP32C3?

Ah, I just realized I made a mistake in my post which I now can’t edit - I’m using the nRF52840 XIAO board, not the ESP32, whoops!

All I’m trying to do is get any kind of UART output such that I can use eg printk or print_uart and see the output on something like RealTerm or TeraTerm. I tried connecting pins 6 and 7 (if I could get output on the USB that would also be fine) but they don’t seem to work as-is. I’m currently working with the echo_bot example as a baseline, and using the default baudrate of 115200.

I figured out how to get UART on pins 6 and 7, it seems there just wasn’t enough power when the board was connected to the xiao expansion board. When I connected it via the USB instead, I got UART out of those pins. Would be nice if it came through the USB itself so I didn’t need an external USB-UART and another cable, do you know how to do that?

Ah’ good troubleshooting,
Yes , The board connected to my jlink provides the power when not connected to usb.
Serial1.println and Serial.println work for output.
GL :slight_smile: