Codecraft Assistant not working

I am using the on-line version of Codecraft with wioTerminal. I have also downloaded and installed the latest version of CodeCraft Assistant. I am using a Seeed ODYSSEY PC using Windows 10. Codecraft Assistant is working but the on-line session of Codecraft does not recognise it and I can not connect to wioTerminal or even any of the other devices like microbit. I am using a Chrome browser.

Perhaps there are some incompatibility issues with ODYSSEY PC. I will report it to the engineer team. Thanks!

This has nothing to do with ODYSSEY. I have tried this now on three PCs - all respond in the same way. There is an obvious defect in Codecraft in the way it works with Codecarft Assistant. Is there a workaround for this? All three computers are using Windows 10.

I have tested it and all seems fine. Would you mind download and reinstall Codecarft Assistant from the website again? Meanwhile, you can check whether the Type-C cable you use is the data-transmitting cable. Some cables are power supply only and not data transmission.

I have already re-installed Codecraft Assistant. No problem with USB cable. The issue seems to be related to our home firewall. We normally use cable internet but yesterday it was not available and I had to use a mobile phone hot spot. During this session I was able to connect WioTerminal from Codecraft Assistant and we able to complete a session. Still not sure why the cable internet service does not work.