Can't send command to Wio E5 Grove (LoRaWAN)

For the first, thanks for the time taken to read this topic, feel free to propose any solutions you think of.

I’m trying to interface my brand new rpi5 to Wio E5 grove card throught GPIO/Grove connections, made with Grove/Dupont cable. Pinout used is below and seems quite standard:

At the first i did’nt get back any output trying to connect to the E5.
I used at first putty and minicom with ttyAMA0 configured to 9600bds 8N1, and later tried 115200 as I saw in the doc a debug mode that can send heartbeat on this rate. But in any case it did’nt worked, my characters are not even print back to my screen.

I then tried to power it with 5V of the rasp, and then magic happens, I received a row of AT:TMEOUT message , and even managed to get AT->AT:OK !

After that, I pasted the AT+UART=TIMEOUT, 0 in the cli, and TIMEOUT message stoped, as any other messages except AT error -24, when i ussue arrow up key or ctrl+c. Still not seeing my character when I type it. But the Tx led on the Wio card blimp at any character I send (I’ve never seen the other 2 led blinking on that board)

As I saw in AT doc that setting UART timeout to 0 suppose using \n at the end of the command, I tried various combinaison to type/paste it in the term, along with CR LF. But no luck on this ones.

I’ve also pu back the wio car to 3.3V, but behaviour remains the same.

I’ll get my hand next week on another rasp (4B this time) to test Wio board along with it. If not better, I’ll probably order new wio E5 board to put away the hypothesis where the first one is broken.

Meantime, if some of you know how to reset the card (saw that devboard and devkit has buttons to do so, only have pins on my side), or any other suggestions, I’ll be greatly appreciated.


I have that same board, but have not had time to experiment with it yet

try using

Hi there are you using the code in this guide?*MQ…&gclid=Cj0KCQjwxqayBhDFARIsAANWRnRsgIS-o3rL2We9liQaGvnK0tc9PW_nuSqvMYK0bhrz1CNb1W7XBFMaAogeEALw_wcB

You should be able to connect to the windows directly and test.
GL :slight_smile: PJ

Thanks for the link provided, I haven’t tried XIAO environnement yet but that definitiveliy something I’ll do in the future. Nevertheless for that project I use Mediapipe/openCV for image processing, and it is too heavy and dependent of linux lib to run on that kind of chips I think.


Many thanks for the link.
I’ve read this example and it is very interesting, but only applicable to arduino env I think. Could be a very good guideline when I’ll try to work with less consumative app, but it is not compatible on that project wich involve ML (not tiny, already experienced edge impulse for example but it will not match the need for the project purpose).
For the raspberry example I’ve followed he intersting (but french I’m afraid) article


Hi there,
Yes for the Arduino Enviro, But have you connected directly up to it with comm port adapter, to send commands directly?
I had similar experience with Xiao ESP32C3 and GPS module with soft serial.
took some tries but eventually I got it.
GL :slight_smile: PJ

sounds like a baud rate issue or power connections.

Yes, but for troubleshooting if you try using the light weight you can make sure it is not a hardware problem, i am feeling you may have tx and rx reversed but i dont know about that hardware

Thanks for your feedback. Totaly agree with both of you, to troubleshoot I have first to see about wich side of the serial the problem is coming from.
I ordered a USB-UART yeasterday, should have it tomorow. My “old” rapsberry pi that sleep in my work desk will also provide another way to dig in, as in the french tutoriel I’ve sen previously it was the same.
For the arduino env, as I’m not familiar with it will take me some time to make the setup, for that reason I’ll probably keep it for the last resort.

With a mind “let’s try what I can with what I have this week end”, I tried various baudrate, and globaly large number of putty options and tricks. Also tried to revert Tx/Rx, but in this last case I lost the only sign of life of the board: the AT error -24 that come back when I send break sequence. This error make me feel either way my command to the E5 are not properly formated and then misunderstood,(but I tried a large number of terminal option), or the module is in a inconsistent state.

I’ll keep updated tomorow when I’ll get both uart/usb converter and raspberry 4 to test with the board.

Kind regards,

1 Like