Can't program Seeeduino Zero on Odyssey Blue from Linux using Arduino IDE


It isn’t possible to upload an Arduino sketch to the Seeeduino Zero on Odyssey Blue from Linux. I have installed the Seeed SAMD Boards, and selected ttyACM0.

Get Board Info works and reports:

BN: Seeeduino Zeo
VID: 0x2886
PID: 0x8008

But uploading fails with:

No device found on ttyACM0
Failed uploading: uploading error: exit status 1

The EXACT same setup on Windows works and I can program the built-in Seeeduino Zero. I am using Ubuntu 18.04.

Any ideas?

Hello @garysims,

Can you try to RESET the AMSAMDG21 by adding a jumper wire between RST Pin and GND Pin on the 4-Pin header (to the left of SAMD21’s 28 pins) and try again?

Thank you.

It isn’t a reset problem. I have both Windows and Ubuntu on the Odyssey. When I boot into Windows it works. When I boot into Ubuntu, it doesn’t.

Hello @garysims,

Sorry for the late reply. I have just tested on my ODYSSEY-X86. I installed Ubuntu 18.04 and Arduino IDE 1.8.19 and I could upload successfully to the Seeeduino Zero.

Can I know your Arduino IDE version?

Hi @lakshan

Thanks for your reply. So I was using Arduino IDE 2.0. Then I tried Arduino 1.8.19. The earlier version worked. However, I noticed that part of the setup for 1.8.19 is to call some scripts including Once I had done the setup for 1.8.19 then 2.0 started working. It seems 2.0 needs the same setup steps, but the scripts aren’t included with the 2.0 download!

That’s great. Glad it is working now. I think is responsible to fix certain permission issues.

Hi, I’m experiencing a similar board-program problem Using Arduino-2.0.0 IDE with WIO-Terminal on Windows-10. Reverting to Arduino-1.8.19 IDE solves this, but I assume the new 64-bit IDE will be the path of choice so a fix would be good. Thank you, Dave.