Can't get new eRPC Wifi Api working on Wio Terminal

I could work successfully with the atWiFi Api on the Wio Terminal.
Since this Api is going to be replaced by the new rpcWiFi, I wanted to switch to the new Api.
I followed the tutorial
to update the Wio Terminal to the new firmware ( where everything worked as explained in the tutorial on my Windows 10 PC.
(It seemed remarkable that the firmware files were much smaller than they were before. Is this correct?)
Then when I tried to run the first example code from

  #include "rpcWiFi.h"
void setup() {
while(!Serial); // Wait for Serial to be ready
// Set WiFi to station mode and disconnect from an AP if it was previously connected
Serial.println("Setup done");

the program reached to line: WiFi.mode(WIFI_STA);
but didn’t return from this function.
What could I be doing wrong?
Kind regards

After another try following this video tutorial I finally got it working.

I don’t know what I did wrong before.
Thanks to Seeed Studio for the comprehensive tutorial.
1 Like