Cannot get Seeeduino V4.2 to show up in device manager

I have 2 different Seeeduinos V4.2 that I just recently purchased in the past few weeks that I cannot get to show up at all in the device manager so that I can install the drivers.

I’ve tried 2 different computers but both of them are running Windows 10 which is all I have.

Both boards have a green LED that lights up near the reset switch and a blinking blue LED near the USB port.

I’ve tried contacting tech support through email but haven’t received a response so not sure what else I can do.

Thanks for any help that you can give.

Start up Device Manager. Look under “Ports”, do you see any new COM port entry? That’s your Seeeduino v4.2 board. Windows won’t find a driver for it, you have to go to the wiki page for the v4.2 and download the driver, then install it manually. Be aware that many Windows 10 machines won’t allow you to install an unsigned driver (such as this one) without changing the setting in Windows 10 that prevents the install. Look on Google for “unsigned driver install windows 10” for instructions on how to do this.

Also notice on the wiki page that if you want the v4.2 to show up in the boards list in the Arduino IDE, you have to add the location of the file to the list of board file locations in Preferences.

Thanks for the help but it looks like it was the USB cables I was using. I tried 2 different cables at first but apparently both were power only.

After switching to a 3rd cable, I was able to get it to load in device manager and install the proper drivers.