CAN to USB Analyzer v7.10 doesn't work in normal mode

As the title says, I have a v7.10 CAN to USB Analyzer which doesn’t work properly.

I have followed the documentation found on GitHub in order to setup my device. I have installed the driver, and set the bit and baud rates (the green and red lights blink once when device is plugged in). I have also rest the device to Default to see if that would help, but it didn’t.

I have a CAN bus with two devices communicating with each other (they are receiving each other’s messages). I want to connect the CAN to USB Analyzer on that bus and read the messages being sent. As of now, I cannot read any messages on the CAN bus using the Analyzer. If I try to send messages with the Analyzer while in Normal mode, the other nodes don’t receive anything and the Bus Monitor shows Transmit and Receive Errors.

The only thing that works is the Loopback Mode. The Analyzer can send and receive its own messages. On top of that, the other nodes are able to read the Loopback messages from the CAN to USB Analyzer.

Why would the other nodes receive Loopback messages from the Analyzer, but not Normal Mode messages? Why does the Analyzer not read messages from the other nodes?

Thanks for your help.

Hi @cap12
The transceiver indicator flashes at the same time when the converter is powered on, indicating that the internal CPU of the converter is working, which means that the CPU is normal.
This situation is likely to occur in the configuration. Try to restore the default first. Use tweezers to short the DEFAULT two small holes on the side of the terminal, and then power on the converter to restore the default. Then remove the tweezers and re-power the converter. When powering on, observe that the converter flashes a few times at the same time when it is powered on, flashing once, the baud rate of the host computer software port is 2000000; flashing 2 times, the host computer software port Choose 1228800 for the baud rate over there; flash 3 times, choose 115200 for the baud rate over the software port of the host computer; then click to open.
To test the converter, select the CAN working mode to loop back to silent mode, then click the settings and start button, and then click the send single frame button, it should be able to send and receive spontaneously.
Note that when you click the Settings and Start button, the send indicator (red) of the converter should flash; if the red light does not flash, check whether the port number and baud rate on the port side are not configured correctly. Check the port number in the device manager. If the baud rate of the normal port is configured correctly, click the set and start button and the converter’s sending indicator should flash.
If self-transmitting and self-receiving are fine, the working module can select the normal mode, and then click the set and start button, it should be able to communicate with the devices on the CAN bus normally, as long as the CAN baud rate is consistent with the device settings on the CAN bus.

Thanks for your quick reply!

Unfortunately, I have followed all your steps but I still have the same issue.

I have reset the device to DEFAULT. I have set the baud rate and the bitrate accordingly. And the device is self-transmitting and self-receiving fine.

In normal mode, sending a frame causes errors in the Monitor tab. My other device cannot read anything either. Maybe the Analyzer doesn’t receive an acknowledgment?

What is weird is that if I change the mode to “Loopback mode” and do the self-transmitting and self-receiving test again, my other device (Arduino + MCP2515 module) can read the messages. So it’s only in loopback mode that the Arduino receives messages from the Analyzer (I have tried different bitrates with same result).

I still cannot receive anything on the Analyzer (other than the self-receiving test).

Do you have any more suggestions? Thanks.

I just bought my USB-CAN Analyzer v7.10 and I believe I am in the same boat on my Windows 10 Pro, it shows up on COM7 but once I connect it with a USB cable both the red Send and the green Rev LEDs just flash once and that is it

also my CAN device requires 500 Kbps but that is not even an option in the bps pull down

I have a Microchip CAN BUS Analyzer and it works fine with my computer