Can not find Barometer Sensor(BMP180) in iOS app

I can’t find the sku_101020072 Grove - Barometer Sensor(BMP180) inside the iOS app.

I tried the driver for Barometer BMP085, but it doesn’t work.
I get the error message {“error”: “timeout when waiting response from Node 7727”}

Hi alexander,

The driver for Barometer BMP085 should work. The registers of bmp180 are compatible with bmp085. The error you get may be caused by network problem.

Which server have you select in the app? and which country are you in ?

Strange, now it works.

But I wonder why I also get “altitude” and “temperature” values, beside that they seems to be wrong.
The “temperature” shows me around -155 °C, but I am still alive :wink:
The “altitude” is about -440 m !?

I have the same problem as Alexander Grein. I just received the kit - and have been testing. The temperature and humidity sensor works fine (though the values are off - is there any way to calibrate them?). But the real problem is the Barometer BMP180. I have tried two different wio links. The temperature is -44.65 c, altitude=12163.08 and pressure=18778. Am I doing something wrong?


I have a spot for the barometer in the i2c section. One for bmp085 and one for bmp280(compatible to bmp180).

I have not tried it because my bmp280 is still on its way to me.

Hello seeed team,

I have the same problem with bmp180 and bmp085

Still have not understand the exact problem, is the sensor not working? or can’t it be selected in the app?

bmp280 with bmp085 driver now works :slight_smile:

I just got my bmp280 sensor and it Seems that it doesent work with the bmp280 selected.
If I select bmp085 it shows a wrong Temperatur and altitude, not sure with pressure.

Are there any updates or fixes coming???