CAN-BUS Shield v1.0 + Arduino Yun

Hello at all,

I’m new to the forum and a neewbe to arduino as well. A few months ago I bought the CAN-BUS shield V1.0 (03/06/2013) and wanted to get it work with my Arduino Yun. I’m on a project to communicate with Seatalk (Protocol from Raymarin and nearby the same like NMEA2000). The Baudrate of Seatalk is, as I know, 250 kbps.
I tried a lot, but without any success.

So I had a look at the different recommendations on the net and at the Wiki ( ), too. I tried as well different libraries e.g. CAN Analyzer and the SAE J1939 Project.

I tested the Pin 9 and 10 (I know for my version I’ve to use Pin 10), I soldered even CS to Pin 9 but also without any success.

So actually I’m trying to debug my code and the code of the functions to find out whats the matter. After putting mcp_can.cpp into the DEBUG_MODE I found out that the system doesn’t go any further than “MCP_CAN::mcp2515_init”.
On the COM Port I can read the message “Enter setting mode fall”.

So atm I don’t know what to do.

Is the problem due to the Arduino Yun?
Or due to the CAN-BUS Shield?

BTW, for my project I bought the Grove Base shield with some sensors which works (only one shield at a moment) really fine.

Hope you can help me solving this issue.



I need really help :frowning:

No-one can help?

The newest version of the CAN Bus Shield puts the SPI pins on the ICSP header, which some Arduinos require in order to use SPI. The Yún and Leonardo are both in that category along with the Mega. You can make legacy SPI shields work by wiring the SPI pins (11-13) on the shield to the ISCP header of the Yún.