Calibration not working for me

I tried 10 times or more, but I do not get any reliable Voltages with my DSO Quad.

I’ve gone thru all the Calibration steps as displayed on the screen, calibrate exactly to the given Voltage from my multimeter, I save the calibration data and than I’ve a look at the vpp and it’s always wrong.

After calibration I give an input from 5V and the DSO tells mit 6.40 or anything other value, but I never get 5.0.

What’s the problem with the calibration, why doesn’t it work? Any ideas?

Best regards,

I’m having the same problem.
After doing the calibration procedure. The DSO is never right.

And it isn’t off with the Vdc only… after the calibration procedure, it’s also off with the gnd… When the probe is connected to the ground the voltage shows higher.

This is quite anoying… I’m hoping this can be fixed on the short term…



hi, i will be in charge of your problem , so please calm down and tell me the whole story more clearly.

  1. you should have download the latest verison of firmware app2.50 and sys1.50. the “ZERO” and "DIFF"calibration are auto done in these firmware.
  2. input voltage that showed on the top of screen and push/pull the navigatorA to make the voltage showed on each column same as the input voltage .
  3. select the “exit and save calibration results” to exit , and after showing “saving the voltage data”, the screen will change to normal state.
    4 press the "preset button “, and there will be a line of character"save the current setting” at the bottom of screen .
  4. reset the Quad , there should be a line of green characters on the bottom of screen : “reload the parameters from disk”
    i have checked the process of calibration , please compare to your calibration process to find out the cause. also , you can state your calibration step by step to me , i will help to find out the problem .

Hi HugMan,

thank you for your response. I describe what I am doing for channel A:

  1. I enter calibration, let it calibrate ZERO and Diff and after that I provide it with 250mV. It displays +.232V in the VOLTAGE column. With -…+ I adjust it to 250mv.
  2. I am going to the nex line, 0.1V: provide 0.51V, -> +.508V
  3. for 0.2V: 1.0V -> +1.00V
  4. 0.5V: 2.70V -> +2.70V
  5. 1V: 5.15V -> +5.16V
  6. 2V: 10.37V -> +10.4V
  7. 5V: 25.4V -> +25.4V
  8. 10V: I do not have 50-60V, so I adjust to the same 25.4V from step 7.: 10V: 25.4V -> +25.6V (25.4 wasn’t an option)
  10. Save the current Settings
  11. changing the voltage to 5.6V, DSO Quad shows Vpp: +6.40V and Vdc +6.40V -> That’s wrong
  12. Power Off and back on
  13. Still the same Input: 5.6V, DSO says 6.40
  14. 10.36 in, DSO says: 11.2V
  15. 1.40V in, DSO says: 2.20V

That’s the procedure I did very often and always the calibration fails.

Best regards

i have checked your process of calibration on my Quad , and in order to test if the calibration result was stored , i adjust the data showed on the 0.5v column to 2.5v when the input was 3.0v, after the calibration , when i input 3.0v , the Quad show max was 2.56 and the wave is about 2.5v , so , the calibration result was stored correctly
as your Quad, i think the calibration result was not stored . so, please try to format the 2M virtul disk(unselect the quick format option ) and try again. and notice if there is a green array : reload patameter from disk when it power up .
thanks .


I’ve reformated the disk and after powering on I get the message “Parameter record not found”. - That’s ok, because there can’t be any.

I’ve again redone the whole calibration process for Ch-A as described above, but the values are again wrong.

DC Input to CH-A: 2,61V Quad says: Vpp: 3.12V, Vdc: 2.96V
DC Input to CH-A: 7.00V Quad says: Vpp: 7.52V, Vdc: 7.36V
DC Input to CH-A: 10.00V Quad says: Vpp: 11.0V, Vdc: 11.0V
DC Input to CH-A: 15.00V Quad says: Vpp: 14.3V, Vdc: 15.2V

If I power on and off the Quad, it says “reloading Parameter from disk”, but it doesn’t affect my voltage, it’s always wrong.

Edit: Just found out, that the Voltage is most off if I measure in the DC 5V Range. If I chang it to DC 2V the voltage is much more correct as in 5V!?

wolfgang, i have test that in my Quad, it all works. and when input is 2.6v the vpp and vdc are all about 2.58~2.65.
i think it maybe caused by calibration data is not stored eventhough you select the “exit and save calibration”, would you help to test: when in calibration mode as you calibrate for the 0.5v , adjust the data to 2V when the input was 2.6v, and save it .reset the Quad , and input 2.6v voltage and read the wave on the screen . to test if the Quad stored the calibration result .


I calibrated the quad to 2.0 when input was 2.6, I’ve saved the calibration and settings and restarted the quad. My Input is still at 2.6V and the Quad displays Vpp: +1.30V, Vdc: +1.32V now in the DC0.5V range.

After entering the calibration again, before I change anything the Voltage is displayed as 2.50V in the 0.5V Raw (Input still 2.60V). I leave it as it is. Save the calibration and Settings again. Restart the Quad: Vpp: +2.10V, Vdc: +2,14V (Input 2.60V).

And again. I enter calibration mode, choose the 0.5V range, calibrate the input 2.60V to 2.60V. Save the calibration and settings. Restart the Quad, get Vpp: +2.30V, Vdc: 2.34V.

When entering the calibration mode the quad seems to reset all settings, - is this correct? I again enter the calibration mode, get 2.48V displayed, I change it to 2.90V. Save and restart. Now I get Vpp: 2.84V, Vdc: 2.88V.

I calibrated to 2.70V, saved and got: 2.42V instead of the 2.6V.
I calibrated to 2.80V, saved and got: 2.66V.
calibrated to 2.74V, saved and got: Vpp: +2.54V, Vdc +2.58V
calibrated to 2.76V, saved and got: Vpp: +2.58V, Vdc +2.62V
calibrated to 2.78V, saved and got: Vpp: +2.62V, Vdc + 2.64V

Changing Input to 5.0V, get Vpp +5.30V, Vdc +5.32V

It’s completly impossible for me to get reliable readings…

The parameters are stored, there must be any other bug in the calibration?

Best regards

Hi Wolfgang,

You are not alone. The current firmware seems to be an early prototype. Calibration does not work. Trig does not work reliable. Some of the measurements are wrong and the operation of the UI is highly confusing.

I am right now betting on a better 3rd party firmware coming available soon.

Best regards,

it seems your calibration was stored. even the calibration itself is not correct., “When entering the calibration mode the quad seems to reset all settings”, that true. maybe need to considered more . i have reported this to the designer.