Bus heavy using CAN shield with Raspberry Pi

Hello all,

I’m using the 2-Channel-CAN-BUS-FD-Shield-for-Raspberry-Pi and a Raspberry Pi 4.
With the example code I was able to send send data from CAN channel 0:

cangen can0 -mv

and receive it with CAN channel 1:

candump can1

This means that the CAN shield works as expected.
But as soons as I try to use external devices with the CAN shield I’m getting a BUS HEAVY error on the windows tool and no received data on the can shield.
I tried it with the 120 Ohm resistor of the CAN shield and without it. Still the same error.

I used a USB-to-CAN adapter from PEAK:

The external devices that send CAN data are PCAN-Explorer and an ECU that is used in a vehicle.
The baudrate is always 500kbit/s.
If I try to send data from PCAN-Explorer to the ECU it works fine but as soon as I connect one of the CAN shield ports the BUS HEAVY error occurs.
It seems to be some kind of wrong settings problem.
Does anyone have experience with this?

Help is very much appreciated.
Thanks in advance!