Bug with grove 4 channel spdt relay

I use several 4 channel relay in a project and I wanted to assign an adress for each of my channel.
I did it for the first one I gave him adress 1, then adress 2, adress 3 and when I want to give the fourth one the relay is not recognized anymore.
I tried for several channel and it still the same. I don’t know what happen, but when I do it I can’t pilot them anymore.
I did a loop to try every i2C adress and it did not switch after I changed the adress to 4, it works with those I did not change to 4
It was done with the multi channel relay arduino library.

You cannot assign multiple addresses to a 4 channel, you can only assign a separate address to it.

I have several 4 channel. I need 16 relays for my application.
So I wanted in my program to adress them as 1, 2 ,3 and 4. But for the 4th one it always “kill” the 4 channel.
I have 4 groves that I tried to assign adress 4 and they don’t work anymore.
If I try to communicate with them I have a no I2C found.
I would like to know if there is a way to restore my groves which does not work anymore and to warn that, the adress 4 might be problematic for 4 channel .

You can try to re-burn the firmware using J-link from the SWD interface, here is its firmware address.

I don’t know how to do it.
Can I use my arduino to do it ? Can I use a ST-Link V2 for STM8 STM32 ? Or does it need to be a J link from Segger ?
My chips are MM32.