Broken Odyssey after bios update

Hi All,

A friend from Canada sent me his odyssey X86j4105.

Everyhting was working fine.

The I tried to update the bios following exactly theses instructions : Installing OS - Seeed Wiki

I left it allone for one hour, but nothing.

Then I tried everything I could imagine to make it work (reset the cmos by unplugging the battery, etc…)

It is now dead.

It seems that other people are affected.

It there anything we can do for it or will it just end up being another ewaste?

Can the bios chip be changed?

Best regards,


@N3ST We suggest you contact distributor you bought before to get after-sales service.

Hi Bruce,

Unfortunately it is not an option, due to the strike in Canada I can’t send back the Odyssey to my friend, plus it is out of warranty.

It would like to try to fix it my self I you could provide the bios eeprom and how to change them.

I would very much like fix it instead of just sending it to the bin.

The right to repair movement it gainging momentum (see what Valve just did with its steam deck and Ifix it).

Could you help me with this?


I have exactly the same problem with my non-eMMC X86J4105. The BIOS.nsh successfully wrote and verified the flash, but on the next start nothing happened for more than thirty minutes.

I have tried multiple times to remove power and battery. When I connect the PSU again, it starts immediately without pressing the power button, but does not initialize the HDMI or POST.

I am wondering what the cause could be? The flashing worked, so the BIOS should not be corrupted. What is it supposed to do in those 6-8 minutes on the first start after flashing and what could go wrong there?

Is there some way to revert to a functioning BIOS? Does the Winbond memory next to the NICs contain the BIOS? Would it be possible to flash it with an external programmer?

Thank you!

Hello @N3ST,

Since you did not buy from our website, and warranty from distributor is over, the only solution remaining would be to flash the BIOS chip. Can you find any local repair shop to help you with this? When you download the BIOS files, there is a file with a “.bin” extension. That is the file that needs to be flashed to the BIOS chip.

Thank you.

Hello @leiki,

Did you buy from our online store ( If so you can apply for a repair and I can guide you with the process.

Thank you.

Hi @lakshan,

I bought it second hand, but it was originally purchased from the Seeed online store.

@leiki Is it possible to send it back to us through the original buyer and we will help with the repair?

It might be possible. What kind of costs would I have to expect?

Hi Iakshan,

Do you have a how to for flashing it, I will try to do that with a friend.

Where is located the bios chips?

Best regards,