Bootloader Mode not working?


I have two WIO Terminal devices that behave the same way. Both have been used only to run demo files from the Arduino IDE.

I want to install uf2 files for the LoRaWAN Gateway Tester project.

I can put the device into bootloader mode by double clicking the slider button, the blue LED fades on and off, and the “Arduino” folder appears in File Manager (Win10) as expected.

The folder contains the three files as expected - CURRENT.UF2, INDEX.HTM, INFO_UF2.TXT

The contents of INFO_UF2.TXT are:

UF2 Bootloader v3.7.0-79-gd73dd64 SFHWRO
Model: Wio Terminal
Board-ID: SAMD51P19A-WioTerminal-v0

When I drag a uf2 file into the folder, I am expecting the device to reboot, but nothing happens.
I have also tested with other uf2 files with the same result.

What am I doing wrong?

Do I need to install a new bootloader?

Any help appreciated.


Could I ask for anyone with WIO Terminal who has successfully used the UF2 Bootloader to check the version number in the INFO_UF2.TXT file and let me know the result please?

Looks like I may have resolved the issue.

It seems that there may be a problem with the WIO Terminal fimware on early shipment devices that prevents the uf2 bootloader from working.

But the solution is easy - just load up a (suitable) project that supplies the Arduino .ino and supporting files using the Arduino IDE and it should update whatever is causing the problem with the uf2 Bootloader.

After doing that, I retested the uf2 Bootloader and it all worked ok.