BLE Micro (v1.2) I am not able to solve this issue

I have bought a BLE Micro.

  1. I downloaded “nRF Connect App for Android” on the phone.
  2. I downloaded Arduino Library “” and also “RedBearLab/nRF51822-Arduino”
  3. I open Arduino Blink sketch, selecting board “Generic nRF51822” or “redBearLab nRF51822”.
  4. I generate .Hex file, send to the phone, and I am able to upload as “application” with the nRF connect App. It also asks for a .dat file, but it can upload th .hex file even if it is missing (how should I create it?)
  5. Application is downloaded, 100%.

But nothing happens! I tried both nrf_gpio_pin_set(xx) and clear, and also digitalWrite, but no way any of the pins shows any sign of life. I tried with multimeter, they stay about 300mV fixed. Also with an led connected both to vcc - or gnd, and the pins. Nothing. What am I doing wrong?
Also the pinout is not 100% clear, I looked at and tried pin 3, 30, 25,26,29, … always no results.
Any help would be greatly appreciated.

This is a very old Seeed product.At present, it is a software update, and the documentation is not updated timely

I bought it after seeing this post, is 8 months “very old” for a product?

Is it replaced by a newer product in the same size, with Arduino support?
Thanks Support for BLE Micro is also very simple. You can use it by adding the pin definition of BLE Micro to the rest of the board.