Battey / Lipo XIAO - Issue

I now have 3 XIAO board that will charge over USB just fine - how ever when they are unplugged from the USB port the board shuts down.

After reading several posts and testing various methods i am yet to find a way to have the board run without the USB Connection

I have tried inducing various current draws - using Leds and sensors - I have tried altering the code as some have said the serial affects it…

I have yet to find a solution to why this is happening on some boards, yet others are fine.

The best i have done to date is to bridge the connection to the 3v3 pin to keep the board powered up (Not advisable)

Keen to know if others are having the same issues - or if there has been a work around on this to get it going.

Hello, which XIAO is it?

Esp32c3 is the board

It would be good to see how you have connected the battery- a circuit diagram or description. It would seem the battery is now connected to the board.

The battery is connected via the pads on the rear of the board… as mentioned the only way to power the board is to jump the positive connection to the 5v connection on the board with a bridging wire.

The battery does charge when plugged , it appears that the link from the battery to the board via a trace on the PCB has been left out…

We did a test a while ago, using a simple Blink program, and the XIAO ESP32C3 worked fine with only the battery connected, and the GPIO was able to output a jump in voltage. However, it should be reminded that the 5V supply pins will not output 5V when the battery is powered, which is the design of the hardware.

How many volts is the 3V3 terminal, 5V terminal and battery pad, when the USB is unplugged?

When connected via battery only

Battery 4.2v

5v connection = 0v
3v3 = 0v

GPIO set to high measuring from ground or battery terminals = 0v

When plugged in all works fine via the usb power

Sounds like there is a batch or boards then that’s not working correctly…

I believe XIAO has a built-in PMOS switch circuit that switches between battery voltage and USB 5V.
Disconnecting USB should switch to battery, but I suspect it is not working properly.

1 Like

Yes :+1: I think you’re right.

The board does say it can be powered via the 5v pin So for now a switch between the battery and the 5v pin will do the job…

Only issue with this is that the connection to the 5v pin needs to be off when the board is charging.

For now that’s the only work around I have found.

Then if this is the case you say, this should not be a product defect problem.

Nope the boards i have are faulty - others can run straight off the battery terminals - where as the ones i have need a wire soldering from the battery + to the 5v pin on the board.


I have 2 of these seeed xiao esp32c3 boards that I plan to use for a project and they need to be powered by rechargeable 3.7v batteries. I am having the same issue as you, neither board will run off the battery without a bridge or work around, which sucks because I really need it to work.

Ah okay :+1: yep looks like a pcb issue then some where down the line or hardware issue

I have also been working with a TTGO Display S3 ESP32S and to enable the battery you have to set the GPIO pin 15 to output and High and then the board will run off the Battery, i do wonder if this is the same with the XIAO but really need the Devs to confirm the workings of the board in more detail

Please see the link below, there may still be a schematic for XIAO_BLE. I checked before and the power supply circuit was the same as the XIAO_ESP32C circuit.

Seeed Studio XIAO nRF52840 Sense — スイッチサイエンス

I had a test with a few of the pin setting as well as the board manager - nothing there that I can see.

I’m uploading my code via Arduino - have check the pin out in the board file and nothing in there regarding pin out for battery :battery:……

For now I’m going to move over to the TTGO T7 boards , fingers crossed this issue gets resolved as it’s a great little board