Atmel AVRISP STK500 USB death on arrival?


I just received the Atmel AVRISP STK500 USB ISP Programmer, but after connecting it to several of my PC’s I think now it was death on arrival.

What I tried so for, see below, all gave the same result, no connection between PC and AVRISP, even no led on the AVRISP is alive…

  • On both a Win Vista 64bit desktop and Win 7 32bit laptop: Installed AVR Studio 4.13 (came with the AVRISP) including the driver. Also installed the separate driver from the cd. Tried to install a legacy device… nothing helped. The strange thing is that I never get to see the “Found new hardware” screen.
  • On a Ubuntu 10.04 laptop: connected the AVRISP and check list of usb devices (lsusb) but the device does not even show up…?

So all the above makes me think it was delivered death… but before I start the RMA procedure and losing a lot of time I would like to ask you guys for advice…

Any help is much appreciated

Thanks in advance,

Kick it up…
Is Seeed Support reading this forum?


Please feedback your issue to “”.