Ardupy-aip install error

Hi all, I have a problem with installing AIP on Python 3.10. I enclose the error I receive below. Can someone help me? Thanks in advance.
Gianfranco

(pipenv) C:\Users\gianf\pipenv\Scripts>pip install ardupy-aip
Collecting ardupy-aip
Using cached ardupy_aip-1.0.0-py2.py3-none-any.whl (35 kB)
Requirement already satisfied: pip>=20.1 in c:\users\gianf\pipenv\lib\site-packages (from ardupy-aip) (22.0.4)
Collecting pyusb
Downloading pyusb-1.2.1-py3-none-any.whl (58 kB)
---------------------------------------- 58.4/58.4 KB 1.0 MB/s eta 0:00:00
Collecting colorama
Downloading colorama-0.4.4-py2.py3-none-any.whl (16 kB)
Collecting demjson
Using cached demjson-2.2.4.tar.gz (131 kB)
Preparing metadata (setup.py) … error
error: subprocess-exited-with-error

× python setup.py egg_info did not run successfully.
│ exit code: 1
╰─> [1 lines of output]
error in demjson setup command: use_2to3 is invalid.
[end of output]

note: This error originates from a subprocess, and is likely not a problem with pip.
error: metadata-generation-failed

× Encountered error while generating package metadata.
╰─> See above for output.

note: This is an issue with the package mentioned above, not pip.
hint: See above for details.

I solved it by installing setuptools version 58 with the following command
pip install setuptools==58

But now I have this other error and I don’t know how to fix it, does anyone have a suggestion?
TKS
(pipenv) C:\Users\gianf\pipenv\Scripts>aip build --board=wio_terminal
Traceback (most recent call last):
File “C:\Python310\lib\runpy.py”, line 196, in _run_module_as_main
return _run_code(code, main_globals, None,
File “C:\Python310\lib\runpy.py”, line 86, in run_code
exec(code, run_globals)
File "C:\Users\gianf\pipenv\Scripts\aip.exe_main
.py", line 7, in
File “C:\Users\gianf\pipenv\lib\site-packages\aip\main.py”, line 52, in main
from aip.command import commands_dict, parse_command
File “C:\Users\gianf\pipenv\lib\site-packages\aip\command.py”, line 46, in
from aip.build import buildCommand
File “C:\Users\gianf\pipenv\lib\site-packages\aip\build.py”, line 40, in
from aip.utils import SerialUtils
File “C:\Users\gianf\pipenv\lib\site-packages\aip\utils.py”, line 30, in
import demjson
File “C:\Users\gianf\pipenv\lib\site-packages\demjson.py”, line 645
class json_int( (1L).class ): # Have to specify base this way to satisfy 2to3
^
SyntaxError: invalid decimal literal

I solved it but I had to downgrade some packages the release of the necessary packages is this:

ardupy-aip 1.0.0
ardupy-mpfshell 1.1.2
certifi 2021.10.8
charset-normalizer 2.0.12
colorama 0.4.4
demjson 1.6
idna 3.3
pip 21.3.1
pyserial 3.5
pyusb 1.2.1
requests 2.27.1
setuptools 58.1.0
urllib3 1.26.9
websocket-client 1.3.2

I recommend developers to update the installation package to make it compatible with the latest packages.
Greetings
Gianfranco