ArduiPi: how to check it's working

Hi, SeeedStudio and your fans,

I’ve recently bought ArduiPi and have some basic problems.

  1. How do I know ArduiPi is on when I connect to Raspberry Pi or external power source? In general, many boards have some LED on when powered on. But I can’t see any visual indication ArduiPi is properly on.

  2. Which Arduino board is ArduiPi compatible with? It uses ATMEL 328P-AU. And I’ve tried UNO or Duemilanove when I upload sketch. But the message is always ‘stk500 is not responding’. Reset button doesn’t work either.


I also have had problems
Here are the results of my testing. I got it to work, but can’t use Nanpy like I wanted
Testing the ArduiPi Board
Summary of tests of ArduiPi board for possible use in clas
First test
Pluged the ArduiPi into a Raspberry Pi,
Power was set to PI (internal)i at 3.3v
Raspberry pi refused to boot

Set to power to 5V
Raspberry Pi still wouldn’t boot
Disconnected ArduiPi & tried as standalone
Nothing – doesn’t seem to have an LED on board and an LED connected to pin 13 does nothing
Tried again with new board, connected to Rasberry Pi
Nothing, still won’t boot.
Got another board from Vendor, repeated prior tests. Same results
Tried disconnecting the monitor, keyboard and mouse, as Charles-Henri Hallard, the creator of the board, had used the board headless while using it.
The Raspberry booted
I then tried reconnecting the monitor, I am using the composite video connection, keyboard and mouse,to confirm the problems, and strangely, the raspberry boots. Exact same configuration as before, but now works. WIERD
Doesn’t seem to have any sketch loaded (i.e. blink sketch)

Testing the board
After reading through all the comments on Charles-Henri Hallard’s website, I discovered the ArduiPi comes preloaded with the bootloader for the Arduino Duemilanove w/ ATMega328.
I used an Arduino UNO as an ISP and was able to load a test program that checks output on all Analog and Digitial pins (expect Rx & TX) and connected it to a test board I use to check if students have damaged Arduinos in class
All pins work.
It can draw 3.3V from Raspberry, but 5V causes the Raspberry to shut down.

Testing to see if can load nanpy software
The ArduiPi doesn’t have a usb so first tried to see if could use Arduino environment and load libraries for Nanpy program. No luck

Testing FTDI
Tried using FTDI cable with FTDI socket, power on ArduiPI set to 5V external, and power by FTDI cable, failure, programmer not responding, seems draws too much power
Tried again with AC/DC converter to supply external power, failure, programmer not responding
Tried connecting DTR to reset pin, failure programmer not responding
Tried pressing reset just as uploading, failure programmer not in sync
Tried using 100nb capacitor between DRT & reset failure, programmer not in sync

Future possible testing

  1. Try using Arduino programmer for board
  2. Remove CPU and load Nanpy by external programmer.

Conclusion so far
ArduiPi is not suitable for use in classroom
No on-board indicators
Abysmally poor documentation
Either can’t be loaded by FTDI or undocumented method must be used

Charles has posted a Getting Started guide for the Arduipi that answers many questions
seems it is an Arduino UNO