Arduino Mega + GPRS v2 + Ethernet shield

Hi folks,

I’m trying to add an ethernet shield to my currently running arduino mega and GPRS v2 shield.
I have already found the hint to jumpwire pin 7 and 8 to 10 and 11 to make the softserial interface working on the mega.
This set-up is running just fine.

Since I would also like to have the Arduino being ethernet connected I’m having trouble with the the softserial interface because pin 10 to 13 are used by the ethernet shield.

If I jumpwire pin 7 and 8 to e.g. 14,15,50,51,52 or 53 it isn’t working although these pin’s should be able to handle change-interrupts.
With these pin’s I’m receiving no serial input at all.
And yes I didn’t forgot the change the SoftSerial code to the associated pins :wink:

I would really appreciate if somebody could get me going on this one.

Thanks in advance and best regards,


Sorry this isnt an answer to your question but rather asking you how you managed to get the GPRS V2 shield working with the arduino mega. Also a question about the requirements on the sim card you can use with the shield.
Any help would be greatly appreciated

I have solved this issue by simply moving to hardware serial communication instead of softwareserial.
For this I have sligthly bended the pin 0 and 1 to the outside so they aren’t connected anymore with the Arduino to prevent interference with the serial 0 port on the Arduino.

After this I jumpwired pin 0 and 1 of the GPRS schield to pin 18 and 19 (Serial 1) of the Arduino.

If you also can use software serial (pin 10 and 11 unused) you can use the softwareserial setup described in the following topic:

Regarding your SIM question I have no idea but this probably is described in the documentation.
I just used a first available SIM card and it simply worked.