Arduino IDE Boards manager not showing Seed boards

I have just bought the Seeeduino Xiao board and was trying to get it to work with the Arduino IDE.

I have put the following URL into the additional boards manager list of URLs

However, when I go to the Tools->Boards->Boards Manager, I am not seeing any Seeed boards and I get the following error:

Skipping contributed index file C:\Users\anand\AppData\Local\Arduino15\package_seeeduino_boards_index.json, parsing error occured:
com.fasterxml.jackson.databind.JsonMappingException: Unexpected end-of-input within/between Object entries
at [Source: (FileInputStream); line: 3805, column: 1304]
at [Source: (FileInputStream); line: 3804, column: 26] (through reference chain: cc.arduino.contributions.packages.ContributionsIndex[“packages”]->java.util.ArrayList[0]->cc.arduino.contributions.packages.ContributedPackage[“tools”]->java.util.ArrayList[47]->cc.arduino.contributions.packages.ContributedTool[“systems”]->java.util.ArrayList[3])

I checked the .json file and it is truncated abnormally. So, there seems to be some issue when downloading this file.

I would be very grateful if anyone can help to resolve this issue.


Hello, i have the samedi problem with seeeduino nano, i don t fond it in the board manager…

I am also facing the same problem - In Board manager I couldn’t see SEEED XIAO nRF board

Try to VPN ?

Sounds like a network problem.

It resolved - I tried with version 1.8 . Earlier it was 2.0

I have this problem too. I can not use any of my XIAO devices. I am using the latest Arduino 2.0. What do I do?

Can you provide more information? For example error logs etc.

You must have fixed something because it works now. I did not do anything differently to look for the board than I did before, but it worked this time…