Arduino 1.8.13 doesn't recognize Grove Beginner Kit for Arduino

A participant in one of my workshops is using the New wonderful Grove Beginner Kit for Arduino. Thank you. I think this will help a lot of teachers to keep track of the components which always get lost. . . !

She is using a Macbook Air circa 2017 13" with OS Catalina 10.15.7.

She’s installed the driver correctly because we can get it to show correctly under the port.

However, when using Arduino 1.8.13, she chooses the board option for Arduino Genuino/UNO and gets an error message when compiling a known blink sketch that says,
“Error for compiling for board Arduino Genuino/Uno.” It also says bad CPU type in Executable.

I am not having the same problem with my Macbook air circa 2015 running Mojave. Can you suggest anything else to try besides what we have done:
restart computer
redownload arduino ide
switched USB port to second port on Mac
redownload Grove Beginner Kit driver


One of my students had this problem a few days ago. Restarting the Arduino IDE resolved the problem.

This does not seem to me as a Mac software problem. I think that it is referring to your selection of processor that the Arduino is building for. In the top menu under the “Tools” check which “Board” is selected and make sure it is for the one you are using. From your message, it looks like you are compiling for a Genuino/Uno type board. If this is not correct, then choose the board that you are using.

It’s the Grove Beginner Kit, which has a built-in board that is supposed to be a Genuino/Uno type of board. I made sure she was selecting the Genuino/Uno. That’s what is so mystifying. I have the participants in my class using both the Seeedstudio Starter Kit for Arduino and the Grove Beginner Kit. I am actually testing out the Grove Beginner Kit for Seeedstudio because it might help teachers out with the nightmare of organizing all the little components. I have her going to get a dongle to see if it is the physical connection between the port and the beginner kit that is the problem, because I don’t have a problem with my older Mac Air! Thanks for responding and I’d be grateful for any other ideas you have!

Ok, have you tried the “verify” option which only compiles, and does not download. That would eliminate anything but the Arduino libraries and compiler. I am using Arduino 1.8.13 with Mac OS X 10.15.7 with no issues. Is it possible that some libraries are still missing ? Perhaps if you post a picture of the error, we might be able to trace back the libraries to see where the error is. blane

I just bought a Grove Beginner Kit for Arduino from the Seeeduino website. The preinstalled demo worked very well. I also have Arduino IDE 1.8.15 installed on my Windows 10 machine and it has been working fine with my Arduino Uno. To connect the Arduino IDE to the Seeeduino Lotus on the Grove Beginner Kit, I installed the driver recommended by the Seeeduino website and I could see the device driver in the Device manager when the Grove Beginner Kit is connected to the PC and it reads COM5 (see picture). However, when I tried to install the BLINK test program, the Arduino IDE had problem connecting to the board (see picture). Did I miss something? Can someone help please?