Arch GPRS kit unable to flash firmware

Hello all,

My ARCH GPRS won’t flash firmware, tried windows xp, windows 8.1, the binaries from the AN11305 on windows, mac and I compiled the xcode project.
All to no avail.
The unit connects ok on all platforms, I see the CRP DISABLD drive, I see a firmware.bin created 23-1-2008, modified 6-2-2009.
Whether i delete the firmware.bin and copy a new firmware.bin or use any of the utilities, the results are the same.

After reconnecting after a seemingly successful flash, the firmware.bin is the original from 2009, so in the end the flash was unsuccessful.

I am grateful for any help!


Hi jvonck,

When you put a new binary into “CRP DISABLD” drive and quick press the button, does “CRP DISABLD” drive keep to pop out?
If it is, the reason is probaly that the checksum of first 8 words(4 bytes) is not zero. Have a look at
Then try the attached binary file — count_LPC11U24.bin.

And what development tool do you use? (3.24 KB)

Thanks for your help sofar!

it does not come back. after a short press it does not reconnect to the computer, only after a long press it reconnects and shows the drive ( with old firmware.bin )

I used, for a first check of the system, ARCH_GPRS_Test_LPC11U24.bin and imported this project in mbed online, compiled etc.
I followed the instructions on

i compiled your c source and tried:
MacVonck-14:Downloads Jan$ …/firmware.bin ARCH_GPRS_Test_LPC11U24.bin
MacVonck-14:Downloads Jan$ dd if=ARCH_GPRS_Test_LPC11U24.bin of=/Volumes/CRP\ DISABLD/firmware.bin conv=notrunc
21+1 records in
21+1 records out
10924 bytes transferred in 0.000091 secs (119943919 bytes/sec)

Still the same behaviour, old firmware.bin keeps coming back
Any other suggestions?

my platform is a macbook pro 2010 i5 8Gb mavericks.
I also tried on various windows systems, win8, xp, win7

Thanks in advance!


Hi Jan,

Have you tried count_LPC11U24 in
? It’s tested. We could check if mbed online compiler generate proper binaries.

And try this command:


Hi Yihui,

I don’t have the nocreate option in Mavericks, The times of the firmware on the flash disk don’t change.
When I run the program, I see Led D1 become lit, then off, Led D2 become lit and then both, then all off. Then it repeats itself.
Is that the behaviour count has to show ( I don’t have the source, so I wouldn’t know ).

Definitely something happens! Count seems to run ok since flashing it with ARCH_GPRS_TEST exhibits only 2 dimly lit D1 and D2 less

Conclusion? Mbed online compiler does not generate binaries with zeros in the header?

I created a new project on mbed with only blinky as source
Blinky runs fine also, so mbed compiler is ok

I’ll start debugging ARCH_GPRS_TEST I guess



Hi Jan,

Have you got the problem solved?
I just tried mbed online compiler. It worked.

Hi Yihui,

Yes, resolved!

Thank you for your help!