Application Key - Sensor not showing up on CHirpstack


I am currently testing a S2100 (with 750cm ultrasonic level sensor) with an M2 gateway. I am trying to set up Chirpstack and am having an issue. Here’s what I’ve got working:

  • Gateway is setup on my LAN and my S2100 is transmitting data to it (I see LoRa packets being received)
  • I have setup Chirpstack and following this article (SenseCAP M2 Multi-Platform Gateway LNS Configuration | Seeed Studio Wiki) I have set up my Gateway and it shows Online. I have added the required Javascript function for the S2100.
  • I have created a Device Protocol and an application. However, I can’t get my sensor/device to be seen on the dashboard.

I think my issues lies with the OTAA Application Keys of the sensor. I have tried the one written on the label of the S2100 (which the dashboard tells me is invalid). I have tried the “Only Read Key” and “Full Access Key” shown on the Sensecap portal. I have also tried the Key for the Gateway. My sensor never checks in but I can see it is transmitting data on my iPhone app and the Sensecap portal.

One thing I noticed is that the Only Read and Full Access Keys shown on the Sensecap portal have too many characters. When I paste them into the Application Key field on Chirpstack, it only imports about half the characters and I can’t type any more.

Any ideas what I could be doing wrong?