App crash when select a node

After configuring the wio link board, I can see there is 1 node in my Android App.
Clicks on it and the app crashes. See the screen cap below. (replace [dot] with . because I can’t post link…)



Clicks on Api or Setting cause app crash too.
Tried my 2nd wio link board. Also same. :cry:

Could your log more info about your phone and OS version?

And, pls update Wio Link app to 2.2.0.

Yes I am already using 2.2.0 (Latest from play store)
I am using a Note 4, android 5.1.

It happens when I tap on any nodes on the screen. (I have 2 nodes)

The stack trace is pointing to:
IndexOutOfBoundsException Invalid index 0, size is 0.

I had the same problem on a Nexus 5 with Android 6.0.1.
After deleting and reinstalling the app, the problem is solved for me.

I hope this will help you.

It seems like previously the app does not get a list of groves. (For unknown reason…)
After uninstall and install, it can get the list and hence the app does not crashes anymore.

Thanks! :smiley: