almost there- but still no mtX Rainbowduino workie

I got the latest firmware uploaded. Had to use my boarduino with the 328 chip, as my ardiuno with the 168 didn’t work, I think because it is using the same port as the rainbowduino or something?

Anyways, now I have opened compiled mtX. No windows or anything show up but the program runs. If I try and open the uncompiled in the latest version of processing, (I am on OSX 10.5.8 on a dual-G5 mac) and run it from there I get the following error:

File /var/folders/oY/oYdPDQkIFkuRtt1Nqq3zqk+++TI/-Tmp-/build6597409964130728353.tmp/ is specified more than once

I am not a total beginner, but nearly so when it comes to java and c++. Any suggestions? I really look forward to trying this out. The rainbowduino has me very excited.


I’ve pushed and updated version of the mac os x version yesterday, there was an issue with different java versions. …

another solution may be to download the source and open it with the Processing IDE. in addition you’ll need the processing launchpad library ( as well.

pls let me know what worked for you, so I can update the docs

Same issues as above still with newest version. Nothing shows up in compiled app and when I try to run it via processing still getting this error:

File /var/folders/oY/oYdPDQkIFkuRtt1Nqq3zqk+++TI/-Tmp-/build6109936448771848992.tmp/ is specified more than once.

I’m on a G5.