A607 Orin NX 8GB Jetson


We would like to get the UART pins working on the SeeedStudio A607 20pin IO Connector (W8). We have tried connecting a Bluerobotics Ping2 Sonar Altimeter and Echosounder but the connection doesnt work with their sample python code. We have tried connecting to it via all of the /dev/ttyTHS devices present under /dev in Jetpack 5.1.1 (Ubuntu 20.04). We have also disabled the console parameters to the kernel to see if that changes things. It does not.

When we connect an oscilloscope the pin is HIGH (3.3V) and does not change.

We have also tried screen and minicom to send data via this connection to no avail.

We have successfully connected a peripheral to RS485_A and RS485_B pins on this connector and this works.

Can you help us? Is there more configuration required to get pin 11 and pin 12 to work for UART communications?


Ben Marsh

I have done further research and found the following in the nvidia forums Replacing Debug serial with normal UART. While we are working with A SeeedStudio A607 this forum link refers to the A603.

Can Seeedstudio or anyone else offer guidance to us about whether this article and the procedure in it is appropriate for us to enable TTL communication on pins 11 and 12 of the SeeedStudio A607 20pin IO Connector (W8)?