4-Digit Display gets stuck

Seems like there’s something wrong with my Grove 4-digit display. It only takes in a few first characters, and then the TM1637::display() function gets stuck forever. I’m guessing it just keeps waiting for the ACK, which never comes.

In the clock example the dots between the number pairs never blinks, and in the flowing characters example the numbers stop at random points. Sometimes it only shows “012”, sometimes it gets to “1123” (which probably means it successfully wrote “0123” and started to write “1234” but got stuck after the first char).

After a couple of hours of trying different things and looking into the library, I tried another display unit (I bought two), which worked immediately with all the examples. So I guess there’s either just something broken in the first one, or there’s some kind of internal variation between the units, which the library cannot handle?

Any idea if I can make the faulty display work, and how? If it matters, I’m using Arduino Uno (r3 DIP, not a clone) and the Grove base shield v1.3.


I am sorry to hear the 4-Digital Display can not work nomally. Before sale, we have tested all module and they are ok. If this has some wrong, I guess that the hardware installation or library file are problematic. Now that you have successfully used another module, Now you can check the first module hardware connection.

Good Luck to you!

Nope, I can reproduce the problem every time by just switching the 1st module in. The 2nd module works every time.