3D Gesture & Tracking Shield for Raspberry Pi (MGC3130) not working

I’ve followed the installation instructions but the demo fails

All that’s displayed is “Basic Init Failed”

Hi there~

Please enable the I2C if you just install the raspbian image. the device is I2C device. We will add a note on wiki page. thanks.

Enable I2C

- Step 1. Run sudo raspi-config.
- Step 2. Use the down arrow to select 5 Interfacing Options.
- Step 3. Arrow down to P5 I2C.
- Step 4. Select yes when it asks you to enable I2C.
- Step 5. Also select yes if it asks about automatically loading the kernel module.
- Step 6. Use the right arrow to select the button.
- Step 7. Select yes when it asks to reboot.

For more info about raspi-config, please refer to [url]https://www.raspberrypi.org/documentation/configuration/raspi-config.md[/url]

Thank you, that solution worked for me.