20180801 lxqt image


I just got my Core v2 board and I’m trying to follow the getting started guide.

I flashed an SD card with respeaker-debian-9-lxqt-sd-20180801-4gb.img.xz and tried to boot it. I’m getting no TTX connection on the OTG USB port. I tried both on a Mac and on a Linux machine and no serial connection seems to be established. There is no device appearing under /dev.

There is activity on the user LEDs: USER1 blinks the heartbeat; USER2 says on solid.

A green LED comes on on the other side, but not always the same one.

There is no activity on a connected HDMI monitor.

I have waited a few minutes and nothing changes. Is there any way to check what’s going on (I don’t have a UART-to-USB adaptor).


Hi there, I just download the respeaker-debian-9-lxqt-sd-20180801-4gb.img.xz and use the etcher to burn it to board, it works. Here is the screen output. Actually, we do verify the firmware previously. do you see any error during etcher burning process? If no, please download the image once again and test. please do let us know if the issue is still there. thanks.

Debian GNU/Linux 9 v2 ttyGS0

respeaker.io Debian Image 20180801

Support/FAQ: http://respeaker.io

default username:password is [respeaker:respeaker]

v2 login:


Hi Bill,

Thank you for replying. I’m sure the image is fine - I have checked both the SHA hash for the downloaded file, and there were no errors in Etcher. I have actually tried with the previous image as well (20180610), and the current one multiple times. There’s always the same result: the board looks alive, with LEDs active, but I get no connection on the OTG. I’m thinking there may be some hardware issue with the Corev2 board itself, or with the USB cable.

Is there a way to tell from the LED activity if the board has booted fine?

Is there supposed to be anything shown on the HDMI output (or does that only work for the Android image)?

How long does the boot process normally take?

I have a UART adapter arriving later today and I’ll try to use that to debug what’s actually happening…



Is there a way to tell from the LED activity if the board has booted fine? pwr is green, user2 is solid blue, user1 is blinking. all leds at backside are off.

Is there supposed to be anything shown on the HDMI output (or does that only work for the Android image)? it has the image on the hdmi interface.

How long does the boot process normally take? it is around 40~50 second for the whole bootup.

I also attached bootup video for your reference. thanks. <LINK_TEXT text=“https://github.com/SeeedDocument/forum_ … r_boot.wmv”>https://github.com/SeeedDocument/forum_doc/raw/master/image/respeaker_boot.wmv</LINK_TEXT>



Hi Bill,

Thanks for your reply, and in particular for the video! That was a very good idea! :slight_smile:

There’s something wrong with my set-up: the USER2 LED is blinking in your case, but for me it says solid on. I also get some green LEDs on the other side on when I boot (but different ones every time).

Once my UART adaptor arrives later today I’ll be able to connect to the console and hopefully find out what’s wrong.

Thanks for your help so far!

Hi Bill,

Just wanted to post a message to close this topic, and maybe help others who may encounter the same problem.

The issue was with the way the Linux kernel works with some older SD cards. Those cards are missing some command and the kernel is unable to read from them. When using a UART serial connection, this problem is reflected as a long series of messages like this on the console:

</s><i> </i>[ 2.119560] mmcblk0: timed out sending SET_BLOCK_COUNT command, card status 0x400900 [ 2.128134] mmcblk0: command error, retrying timeout <e>

This kernel bug (actually a misconfiguration) is reported widely on the internet; for example here’s the Ubuntu bug for it: <LINK_TEXT text=“https://bugs.launchpad.net/ubuntu/+sour … ug/1333140”>https://bugs.launchpad.net/ubuntu/+source/udev/+bug/1333140</LINK_TEXT>

The simplest option to avoid this problem is to use a more recent SD Card, one that supports all the eMMC commands. For reference, I got a SanDisk Ultra and that worked perfectly fine.

My Respeaker Core V2.0 board now boots without problem!



thanks for keeping us posted. we will add a note into our wiki. thanks.