2.8 TFT Will not seem to work. What am I doing Wrong?

I just recently purchased an 2.8"TFT Touch Shield for the Arduino. I am using an Arduino Duemilanove with a 328 inside. I was searching and found this post that was toward the beginning of the forum, as in a long time ago.


I never saw a final solution and I am having the same problem. The white screen you see in the picture on the above forum is what I am seeing. The code compiles correctly and I just don’t know what I am doing wrong. Thanks for your help.

Hi ,
The example I have tested via arduino - 1.0, it work fine with my Uno . Can the demo code upload to your Arduino ?


Yes the demo uploads successfully.

I am having the same problem.
Today I receive Seeeduino Mega and 2.8 TFT shield. Tried the demo, upload code successfully, but the screen just lights up and shows nothing. I use Arduino 1.0.1 and this TFT Library

Only one example “touchscreendemo” (with empty screen), but data is strange: Raw X constantly 1023 and Raw Y constantly 0, only Pressure is changed
Raw X = 1023 Raw Y = 0 Pressure = 46
X = -38 Y = 366 Pressure = 46
Raw X = 1023 Raw Y = 0 Pressure = 124
X = -38 Y = 366 Pressure = 124
Raw X = 1023 Raw Y = 0 Pressure = 479
X = -38 Y = 366 Pressure = 479
Raw X = 1023 Raw Y = 0 Pressure = 214
X = -38 Y = 366 Pressure = 214

Hi DzurDzen,
If you use Mega , you need to change some code , there is a note at the file “readme” .


Hi Roxide :slight_smile: ,
Sorry for the inconvenience brought. Hope you can try to use another Arduino board and do not connected with other modules , then upload the demo code “TFT-drawCirecle” via arduino - 1.0 but not arduino - 1.01.
If it still can not work , please refer to the schematic , and check the if connection fine. After that , it still not work , you can contact our engineer :kevin.hai@seeedstudio.com for more details , thanks``


It’s work! :slight_smile: Thanks